Bug 186954 - PS/PDF jobs disappear
PS/PDF jobs disappear
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 12:29 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.2.rc1.2.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 13:02:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log from CUPS after updating (11.25 KB, application/octet-stream)
2006-03-31 13:23 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2006-03-27 12:29:01 EST
Description of problem:
I can't print, opening the CUPS page for printers shows:

  "Unable to open paralell port device "/dev/lp0": Permission denied"

ls(1) says with -l and also with --lcontext (SELinux disabled on boot because
mount(8) can't get its shared libs, but that happened /after/ the current
problem started):

   crw-rw---- 1 root lp 6, 0 Mar 27 11:53 /dev/lp0

This started when CUPS was last updated, AFAICS. Strangely, I ended up with both 
cups-1.2-0.1.b2.3 and cups-1.2-0.1.b2.6 installed, with cups-libs for the older
version in x86_64 and i386 arches. I deleted the old stuff, a "rpm -V cups
cups-libs" shows no weirdness, and then restarted the cups service.

BTW, now trying to use the Administration page to change settings (save debug
info to try to diagnose this) gets Firefox to wait for a /long/ time without any
visible effect.

Version-Release number of selected component (if applicable):
cups-1.2-0.1.b2.6

How reproducible:
Always

Steps to Reproduce:
1. Enter http://localhost:631
2. Look for printer connected to lp0
3. Print test page
  
Actual results:
Permission denied, nothing printed

Expected results:
Paper waste...

Additional info:
Comment 1 Tim Waugh 2006-03-27 12:56:16 EST
What does 'rpm -q foomatic' say?
Comment 2 Horst H. von Brand 2006-03-27 20:02:23 EST
foomatic-3.0.2-34, that package also checks out clean for "rpm -V"
Comment 3 Horst H. von Brand 2006-03-27 20:05:01 EST
That version of foomatic was installed 20060326, /after/ the problems started.
Comment 4 Tim Waugh 2006-03-28 03:07:02 EST
That version is meant to fix the problem. :-)  I take it that it doesn't?

Please fetch cups-1.2-0.2.rc1.1 from today's rawhide and upgrade to that.  Then
make some trivial change in s-c-printer and click Apply, or alternatively run
this as root:

/usr/sbin/printconf-backend --force-rebuild
/sbin/service cups restart

Can you print now?
Comment 5 Horst H. von Brand 2006-03-28 14:47:40 EST
Nope, same troubles as before. Again, SELinux disabled as it doesn't boot otherwise.
Comment 6 Horst H. von Brand 2006-03-29 12:05:39 EST
After today's update (now cups-1.2-0.2.rc1.2, foomatic-3.0.2-34 hasn't changed;
dit the above rebuild just for luck) I get the same error. Plus still no boot
with SELinux enabled...
Comment 7 Tim Waugh 2006-03-29 12:16:42 EST
http://cups.org/str.php?L1521 describes the reason for this particular problem I
think.  Once I have a patch I'll build a new package to try.
Comment 8 Tim Waugh 2006-03-30 05:13:58 EST
Please try these packages:

ftp://people.redhat.com/twaugh/tmp/cups-devel/
Comment 9 Horst H. von Brand 2006-03-31 13:23:11 EST
Created attachment 127144 [details]
Error log from CUPS after updating
Comment 10 Horst H. von Brand 2006-03-31 13:25:38 EST
Now I can print the test page, printing anything else via lpr "works normally"
(job get shown as queued, printing, then queue empty), CUPS page claims the job
ended normally, but nothing shows up on paper.
Comment 11 Tim Waugh 2006-04-03 06:11:51 EDT
So the test page really does end up on the paper, but no other jobs do?  Strange.
Comment 12 Horst H. von Brand 2006-04-03 11:36:00 EDT
Just tried it after today's round of updates (cups-1.2-0.2.rc1.5,
foomatic-3.0.2-34, reset from #4 plus futzing around with system-config-printer
to see if anything there might shed some light).

Again, can print test page, but nothing else; the CUPS page claims the job
finished normally.

Only strange thing I see in /var/log/cups/error_log is an occasional line saying:

  Unable to set ACLs on root certificate "/var/run/cups/certs/0" - Operation not
supported

SELinux targeted in force (currently selinux-policy-targeted-2.2.29-1)
Comment 13 Tim Waugh 2006-04-03 12:17:02 EDT
I don't think that the 'operation not supported' message is the cause of this. 
I see that here too, but printing works fine.

Any SELinux messages in /var/log/messages, or 'dmesg' command output?
Comment 14 Tim Waugh 2006-04-03 12:56:24 EDT
Also, what's the URI of the queue you're printing to?
Comment 15 Horst H. von Brand 2006-04-03 14:23:36 EDT
kernel-2.6.16-1.2114_FC6, selinux-policy-targeted-2.2.29-1 from today.
The only thing I see now in /var/log/messages is:

Apr  3 14:04:57 quelen kernel: audit(1144087470.403:373): avc:  denied  { search
} for  pid=1358 comm="pam_console_app" name="var" dev=dm-0 ino=118785
scontext=system_u:system_r:pam_console_t:s0-s0:c0.c255
tcontext=user_u:object_r:file_t:s0 tclass=dir

/var/log/messages gets spammed with that... and the system doesn't work (no way
to su, for instance). SELinux disabled (boot: ... selinux=0) for now.

Tried printing again without SELinux: Result is the same as before, just that an
old test printout did show up now (I did not delete the printout of a text test,
as everything before had show up as printed normally). New ones show as
completed normally, no output to the printer; printing the test page from the
CUPS page works...

URI is paralell:/dev/lp0, printer is HP LaserJet 1320 (PostScript)

Comment 16 Horst H. von Brand 2006-04-03 14:58:18 EDT
Just noticed that the text file I sent to the printer doesn't show up in the
Jobs page, as the .ps and .pdf tests do. Still got a few old tests hanging
around now...
Comment 17 Tim Waugh 2006-04-04 05:13:33 EDT
Please remove the old jobs.

What does 'lpstat -p' say? (and which queue is it?)
Comment 18 Horst H. von Brand 2006-04-04 15:48:43 EDT
Cancelled all jobs to the printer. Now:

  [root@quelen ~]# lpstat -p
  printer printer is idle.  enabled since Mon 03 Apr 2006 02:08:13 PM CLT
  printer printer1 is idle.  enabled since Mon 03 Apr 2006 02:26:34 PM CLT

The affected printer is printer1

Tried printing a .pdf and plain text. Both show as completed normally, but only
the text shows up printed out.

Coincidentally (?) eggcups crashed, but it isn't on the "Inform developers" list...

The job numbers were 270 and 271, and in /var/log/cups/error_log I get lots of:

  E [04/Apr/2006:15:44:59 -0400] Get-Job-Attributes client-error-not-found: Job
#267 does not exist!
  E [04/Apr/2006:15:45:04 -0400] Get-Job-Attributes client-error-not-found: Job
#268 does not exist!

(Just those two, over and over).

Now tried a .ps, again "completed normally", but no output.
Comment 19 Horst H. von Brand 2006-04-06 17:08:12 EDT
Just for fun, tried a little experiment: From the same rawhide on a i686
(laptop) print to a networked PostScript printer. cups-{,libs-}1.2-0.2.rc1.6,
foomatic-3.0.2-34; check out clean for rpm -V; did the magic chants as in #4.

Same results, i.e.:
- Test page prints fine
- Plain text prints fine
- PostScript "completes normally", but no output ever shows up.

/var/log/cups/error_log says for each:

  [root@laptop11 packages]# egrep 93[7-9] /var/log/cups/error_log
  I [06/Apr/2006:16:51:42 -0400] Adding start banner page "none" to job 937.
  I [06/Apr/2006:16:51:42 -0400] Job 937 queued on "printer" by "guest".
  I [06/Apr/2006:16:51:42 -0400] Started filter /usr/lib/cups/filter/pstops (PID
  4054) for job 937.
  I [06/Apr/2006:16:51:42 -0400] Started backend /usr/lib/cups/backend/ipp (PID
4055) for job 937.
  N [06/Apr/2006:16:51:43 -0400] [Job 937] Print file accepted - job ID 57.
  I [06/Apr/2006:16:52:05 -0400] Adding start banner page "none" to job 938.
  I [06/Apr/2006:16:52:05 -0400] Job 938 queued on "printer" by "vonbrand".
  I [06/Apr/2006:16:52:05 -0400] Started filter /usr/lib/cups/filter/pstops (PID
4069) for job 938.
  I [06/Apr/2006:16:52:05 -0400] Started backend /usr/lib/cups/backend/ipp (PID
 4070) for job 938.
  N [06/Apr/2006:16:52:09 -0400] [Job 938] Print file accepted - job ID 58.
  I [06/Apr/2006:16:52:14 -0400] Adding start banner page "none" to job 939.
  I [06/Apr/2006:16:52:14 -0400] Job 939 queued on "printer" by "vonbrand".
  I [06/Apr/2006:16:52:14 -0400] Started filter /usr/lib/cups/filter/texttops
(PID 4078) for job 939.
  I [06/Apr/2006:16:52:14 -0400] Started filter /usr/lib/cups/filter/pstops (PID
4079) for job 939.
  I [06/Apr/2006:16:52:14 -0400] Started backend /usr/lib/cups/backend/ipp (PID
4080) for job 939.
  N [06/Apr/2006:16:52:16 -0400] [Job 939] Print file accepted - job ID 59.

URI is ipp://lp-red.inf.utfsm.cl/printers/queue1

Again, I get complaints about two previous jobs <not existing, here 934 and 935,
while the jobs I sent were 937 (test page), 938 (.ps), 939 (text).

Also, restarting cups gives me reports on "correcting ownership" of a bunch of
files, so rpm -V complains:

   ......G.    /etc/cups
   S.5...GT  c /etc/cups/cupsd.conf
   ......G.    /etc/cups/ppd
   S.5...GT  c /etc/cups/printers.conf
   ......G.    /etc/cups/ssl
   ......G.    /var/spool/cups
   ......G.    /var/spool/cups/tmp

Why isn't this with the correct group ownership in the RPM?
Comment 20 Tim Waugh 2006-04-07 04:16:56 EDT
The group ownership is correct for the default configuration.  Unfortunately
it's different than the configuration we shipped for 1.1.x. (Please report
separate issues like this separately -- it makes it much easier for me to track.)

Are you still getting 'permission denied on /dev/lp0'?
Comment 21 Horst H. von Brand 2006-04-07 10:02:32 EDT
OK.

Nope, there are no permissions problems anymore. But (as stated) I can't print...
Haven't been able to get today's update yet, will call back.
Comment 22 Paul F. Johnson 2006-04-07 10:18:08 EDT
Are you running the 1.2-0.2.rc1.7 version?

I've got it on my x86_64 and x86 boxes and all of them are happy printing to USB
and lp0 (I have an HP980 on the USB port and ML2250 on lp0. Prior to rc1.6, I
could print to lp0, but not USB).

Comment 23 Hans de Goede 2006-04-07 10:19:09 EDT
I see the same (x86_64 too!), although after updating to todays rawhide (which
probably fixed the permission part) I got printing to work from openoffice, hey
ooo is i386, I smell a rat here!
Comment 24 Hans de Goede 2006-04-07 10:29:18 EDT
For the record:
[hans@shalem ~]$ rpm -q cups
cups-1.2-0.2.rc1.7.x86_64
[hans@shalem ~]$ 

From the mail conversation on this on f-d:
> Same here (cups to a PS printer via SMB). Cups test page works, and claims
> that the imageable area is 260x367mm, which is plainly ridiculous (this is
> an A4 printer), although I do now know where those numbers come from.
>
> Printing the A4 test page results in the printer spinning up (so something
> is sent there), but no print is produced in the end.
>

In my case there is a print prodecuded containging the upperleft or was it lower
right? corner of the 1 cm border of the A4 testpage, besides that the page is
all white.

I think this could be relevant maybe ooo overrides the printable area fixing things?
Comment 25 Horst H. von Brand 2006-04-07 12:29:51 EDT
Now tried cups-1.2-0.2.rc1.7 (+ ghostscript-8.15.1-8), on i386 printing a PS
over the net works fine. On x86_64 the PDF job did never even show up in the
queue. Just rebooted (new kernel), will try again later.
Comment 26 Tim Waugh 2006-04-07 12:36:37 EDT
Please try these rc1.2.8 (FC5) / rc1.8 (devel):

  ftp://people.redhat.com/twaugh/tmp/cups-1.2/
Comment 27 Hans de Goede 2006-04-07 12:59:56 EDT
It prints for me now, but the print of a pdf exported from ooo is much smaller
then when printing directly from ooo. The pdf looks fine in xpdf, but it as if
its shrunken / zoomed out when printing. This could the printable area problem.
Comment 28 Tim Waugh 2006-04-07 13:02:32 EDT
Please file a separate bug report for the print size issue.  Thanks.
Comment 29 Horst H. von Brand 2006-04-07 14:09:54 EDT
Re #26: On x86_64 it now prints PDF. But as the system is pretty messed up after
today's round of updates, I can't give more details.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.