Bug 186957 - Native Eclipse does not recognize workspaces created with the Java Eclipse
Summary: Native Eclipse does not recognize workspaces created with the Java Eclipse
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 5
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Keywords:
: 186958 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-27 18:07 UTC by Dimi Paun
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-04-10 16:52:19 UTC


Attachments (Terms of Use)
First page of Help -> About Eclipse SDK -> Plugin Details (55.87 KB, image/png)
2006-04-10 05:47 UTC, Dimi Paun
no flags Details
Second page of Help -> About Eclipse SDK -> Plugin Details (56.96 KB, image/png)
2006-04-10 05:48 UTC, Dimi Paun
no flags Details
Expanded view of Window -> Show View (23.33 KB, image/png)
2006-04-10 05:49 UTC, Dimi Paun
no flags Details
My workspace/.metadata/.log file (346.25 KB, text/plain)
2006-04-10 05:53 UTC, Dimi Paun
no flags Details

Description Dimi Paun 2006-03-27 18:07:17 UTC
Description of problem:
Native Eclipse does not recognize workspaces created with the Java Eclipse.
This makes the native Eclipse unusable in my case.

Version-Release number of selected component (if applicable):
3.1

How reproducible:
Always.

Steps to Reproduce:
1. Open native Eclipse
2. Point it to existing workspace
3. 
  
Actual results:
It display the Welcome page, as if it had a brand new workspace

Expected results:
It should open it as I last saved it.

Additional info:
Let me know if you need anything from the .metadata directory.

Comment 1 Andrew Overholt 2006-03-30 15:45:53 UTC
*** Bug 186958 has been marked as a duplicate of this bug. ***

Comment 2 Dimi Paun 2006-04-10 00:40:16 UTC
This seems to be working now, sorry for the false alarm.
Not sure what went wrong, or what I did right, but I somehow
convinced it to recognize my previously created workspace.

Howevever, I do get an exception now whenever I open said
workspace:

Problems occurred restoring workbench.
  Unable to restore perspective: Workspace - Java.
    Internal error activating an Editor.

The desktop is restored, but the Package View is missing,
and I can not find it anywhere... Is this expected behaviour?



Comment 3 Ben Konrath 2006-04-10 01:25:26 UTC
If you use a workspace that has been created with an Eclipse that has plugins
that are not installed with the current version, you will get a message similar
to that. 

Have tried getting the package explorer back by doing:

Window -> Show View -> Package Explorer

If that doesn't work, can you post a screenshot of:

Help -> About Eclipse SDK -> Plugin Details

Try to make that window as big as possible and include as many of the jdt
plugins as your screen will allow. Can you also post your
workspace/.metadata/.log file. Thanks.

Comment 4 Dimi Paun 2006-04-10 05:47:04 UTC
Created attachment 127532 [details]
First page of Help -> About Eclipse SDK -> Plugin Details

Comment 5 Dimi Paun 2006-04-10 05:48:38 UTC
Created attachment 127533 [details]
Second page of Help -> About Eclipse SDK -> Plugin Details

Comment 6 Dimi Paun 2006-04-10 05:49:50 UTC
Created attachment 127534 [details]
Expanded view of Window -> Show View

Comment 7 Dimi Paun 2006-04-10 05:53:22 UTC
Created attachment 127535 [details]
My workspace/.metadata/.log file

Comment 8 Dimi Paun 2006-04-10 05:59:08 UTC
Adding the Package Explorer from:
    Window -> Show View
didn't work as I could not find it.

I've attached a screenshot of the fully expanded
   Window -> Show View
IIRC, it resides in a 'Java' group that doesn't
even appear in my case. Strange.

I've added screenshots of
    Help -> About Eclipse SDK -> Plugin Details
I had to do it in two pages to include everything.

I've also included my .metadata/.log file as you
requested.

Please let me know if you need any more information.


Comment 9 Dimi Paun 2006-04-10 16:52:19 UTC
<blush>I haven't installed all plugins</blush>

Yes, now I get the "Package Explorer", and the error is gone as well.

Everything works fine now, this is not a bug.



Note You need to log in before you can comment on or make changes to this bug.