Bug 187017 - Console switch in install causes fatal rpm cpio errors
Console switch in install causes fatal rpm cpio errors
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 21:10 EST by Craig
Modified: 2008-04-29 14:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 14:26:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Craig 2006-03-27 21:10:47 EST
Description of problem: I had an FC4 system which I tried to update to FC5.
Install was running fine, but I was worried about disk space. While packages
were installing, I typed Ctrl-Alt-F2 to run df. All was OK, but the install
froze up. On the log screen (Ctrl-Alt-F3 or F4) I saw errors from RPM like
"cpio: lsetfilecon failed - invalid argument"... which seem to be SElinux
related (based on Google resuls). I rebooted, tried again... every time I switch
consoles during the package install, it freezes up anaconda the same way and I
see the same errors on the logging. I was able to install OK when I just left it
running and didnt try switching consoles.

Version-Release number of selected component (if applicable):

FC5 install DVD

How reproducible:

Every time

Steps to Reproduce:
1. Boot install media, pick upgrade, go through with default choices
2. When packages are installing switch to a text console
3. Switch back to X and itll be a dead install process
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-04-10 12:18:14 EDT
What type of video card do you have?  This sounds like X just dying on vt switch.
Comment 2 Craig 2006-04-10 12:44:00 EDT
Video card is some S3 variant... but no, X is not dying. I can switch back to
the X console and X is running just fine. Problem is that the install process
stops, and it will sit there saying "Installing package foo" or whatever until I
get bored enough to reboot the computer. I can switch back and forth between X
and other VTs without X locking up, no matter how many times I switch. If I
switch over to a text console and do a ps after the install dies, there seems to
be no process installing any RPMs even though the X screen will keep on saying
that Anaconda thinks its still installing packages.
Comment 4 Red Hat Bugzilla 2007-06-11 23:08:25 EDT
requested by Jams Antill
Comment 5 Bug Zapper 2008-04-03 22:18:32 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Joel Andres Granados 2008-04-29 14:26:32 EDT
xorg, yum, and anaconda have come a long way since this report,  If you are
still seeing this behavior in f9 or after, plase reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.