Bug 187070 - DS is not installed onto clear Fedora Core 5
DS is not installed onto clear Fedora Core 5
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Nathan Kinder
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 03:18 EST by Oleg Preobrazhenskyy
Modified: 2008-08-11 19:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 12:03:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Preobrazhenskyy 2006-03-28 03:18:51 EST
Description of problem:

When install DS onto Fedora Core 5

[slapd-itan]: starting up server ...
[slapd-itan]:   Fedora-Directory/1.0.2 B2006.060.1951
[slapd-itan]:   itan.tas.com:389 (/opt/fedora-ds/slapd-itan)
[slapd-itan]:
[slapd-itan]: [28/Mar/2006:11:14:41 +0300] - Fedora-Directory/1.0.2 B2006.060.
1951 starting up
[slapd-itan]: [28/Mar/2006:11:14:42 +0300] - slapd started.  Listening on All 
Interfaces port 389 for LDAP requestsYour new directory server has been started.
Created new Directory Server
Start Slapd Starting Slapd server configuration.
Success Slapd Added Directory Server information to Configuration Server.
Configuring Administration Server...
Setting up Administration Server Instance...
Configuring Administration Tasks in Directory Server...
Configuring Global Parameters in Directory Server...
Can't start Admin server [/opt/fedora-ds/start-admin > /tmp/filejVvtKH 2>&1] 
(error: No such file or directory)
You can now use the console.  Here is the command to use to start the console:
cd /opt/fedora-ds
./startconsole -u admin -a http://itan.tas.com:12113/

--- then I tried to run mannually ---
[root@itan sysconfig]# cd /opt/fedora-ds
[root@itan fedora-ds]# ./startconsole -u admin -a http://itan.tas.com:12113/
GC Warning: Out of Memory!  Returning NIL!
Exception in thread "main" GC Warning: Out of Memory!  Returning NIL!
java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
*** Got java.lang.OutOfMemoryError while trying to print stack trace.
[root@itan fedora-ds]# /opt/fedora-ds/start-admin
httpd.worker: Syntax error on line 151 of /opt/fedora-ds/admin-serv/config/
httpd.conf: Cannot load /opt/fedora-ds/bin/admin/lib/libmodrestartd.so into 
server: /opt/fedora-ds/bin/admin/lib/libmodrestartd.so: undefined symbol: 
apr_filename_of_pathname

How reproducible:
Always
Comment 1 Rich Megginson 2006-03-28 10:34:51 EST
There are really two problems here.
1) Can't start Admin server [/opt/fedora-ds/start-admin > /tmp/filejVvtKH 2>&1] 
(error: No such file or directory)

This usually means an incorrect DNS configuration.  Check your
/etc/nsswitch.conf and /etc/resolv.conf to make sure host/domain name resolution
is occurring correctly.  You will have to reinstall from scratch after you do this.

2) In the startconsole shell script, you need to remove the "-ms8m -mx64m"
arguments to the java command.
Comment 2 Rich Megginson 2006-03-28 10:35:36 EST
For 2) above, see also https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=183962
Comment 3 Oleg Preobrazhenskyy 2006-03-28 11:53:52 EST
Can't start Admin server [/opt/fedora-ds/start-admin > /tmp/filejVvtKH 2>&1] 
(error: No such file or directory)

No, your appologize is wrong! That not owned by bad DNS.
Example:

[root@liuba ~]# /opt/fedora-ds/start-admin
httpd.worker: Syntax error on line 151 of /opt/fedora-ds/admin-serv/config/httpd.conf: 
Cannot load /opt/fedora-ds/bin/admin/lib/libmodrestartd.so into server: /opt/fedora-ds/bin/
admin/lib/libmodrestartd.so: undefined symbol: apr_filename_of_pathname

As we can see there is error in DSO
Comment 4 Rich Megginson 2006-03-28 12:03:49 EST
Ah, I see.  I thought you built DS yourself on Fedora Core 5.  The pre-built FDS
binaries do not support Fedora Core 5, and we do not yet have any pre-built FDS
binaries for Fedora Core 5.

See
http://directory.fedora.redhat.com/wiki/Release_Notes#Fedora_Directory_Server_1.0.2_-_03.2F02.2F2006

The information about Fedora Core 5:
"No Fedora Core 5 RPMs at this time, but you can build it - see Building"
Comment 5 Oleg Preobrazhenskyy 2006-03-28 12:38:54 EST
So, I would like to build some.
But... I did not see any link to download sources.
Comment 6 Rich Megginson 2006-03-28 12:57:12 EST
http://directory.fedora.redhat.com/wiki/Release_Notes#Fedora_Directory_Server_1.0.2_-_03.2F02.2F2006

has a link to Building.  The easiest way to build is to use the One Step Build
procedure - http://directory.fedora.redhat.com/wiki/Building#One-Step_Build -
note that is is a little different than just downloading a source tar ball and
doing configure ; make due to the large number of components involved.
Comment 7 Oleg Preobrazhenskyy 2006-03-30 10:00:55 EST
Thanks a lot!
I'd build own FDS rpm under FC5.

That's a log of run

[slapd-itan]: starting up server ...
[slapd-itan]:   Fedora-Directory/1.0.2 B2006.089.1126
[slapd-itan]:   itan.tas.com:389 (/opt/fedora-ds/slapd-itan)
[slapd-itan]:
[slapd-itan]: [30/Mar/2006:18:04:44 +0300] - Fedora-Directory/1.0.2 B2006.089.
1126 starting up
[slapd-itan]: [30/Mar/2006:18:04:44 +0300] - slapd started.  Listening on All 
Interfaces port 389 for LDAP requests
Your new directory server has been started.



Created new Directory Server
Start Slapd Starting Slapd server configuration.
Success Slapd Added Directory Server information to Configuration Server.
Configuring Administration Server...
Setting up Administration Server Instance...
Configuring Administration Tasks in Directory Server...
Configuring Global Parameters in Directory Server...

You can now use the console.  Here is the command to use to start the console:
cd /opt/fedora-ds
./startconsole -u admin -a http://itan.tas.com:38456/

INFO Finished with setup, logfile is setup/setup.log
Comment 8 Chandrasekar Kannan 2008-08-11 19:45:56 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.