Bug 187072 - JabRef does not run with default java
JabRef does not run with default java
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 03:38 EST by FX
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 14:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FX 2006-03-28 03:38:04 EST
Description of problem:
jabref throws up an exception just after popping up its splash screen. I don't
think it's a jabref issue since it runs fine with other javas (such as Sun and
the one in MacOS).

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp_83rh
gcc-java-4.1.0-3

How reproducible:
Always

Steps to Reproduce:
1. Download latest JabRef from
http://prdownloads.sourceforge.net/jabref/JabRef-2.0.1.jar
2. Run it with "java -jar Desktop/JabRef-2.0.1.jar"
  
Actual results:
Splash screen pops up, and then:
Exception in thread "main" java.lang.NullPointerException
   at com.jgoodies.plaf.plastic.PlasticTabbedPaneUI.getTabAreaInsets
(PlasticTabbedPaneUI.java:509)
   at
com.jgoodies.plaf.plastic.PlasticTabbedPaneUI$TabbedPaneLayout.calculateTabRects
(PlasticTabbedPaneUI.java:660)
   at
javax.swing.plaf.basic.BasicTabbedPaneUI$TabbedPaneLayout.calculateLayoutInfo
(libgcj.so.7)
   at javax.swing.plaf.basic.BasicTabbedPaneUI$TabbedPaneLayout.layoutContainer
(libgcj.so.7)
   at java.awt.Container.layout (libgcj.so.7)
   at javax.swing.plaf.basic.BasicTabbedPaneUI.installUI (libgcj.so.7)
   at com.jgoodies.plaf.plastic.PlasticTabbedPaneUI.installUI
(PlasticTabbedPaneUI.java:165)
   at javax.swing.JComponent.setUI (libgcj.so.7)
   at javax.swing.JTabbedPane.setUI (libgcj.so.7)
   at javax.swing.JTabbedPane.updateUI (libgcj.so.7)
   at javax.swing.JTabbedPane.<init> (libgcj.so.7)
   at javax.swing.JTabbedPane.<init> (libgcj.so.7)
   at net.sf.jabref.JabRefFrame.<init> (Unknown Source)
   at net.sf.jabref.JabRef.openWindow (Unknown Source)
   at net.sf.jabref.JabRef.<init> (Unknown Source)
   at net.sf.jabref.JabRef.main (Unknown Source)

Expected results:
Being able to actually work through my bib files with the nice jabref interface.

Additional info:
I can provide any debugging info you think usefull if that bug turns to be
non-reproducible on your end.
Comment 1 Thomas Fitzsimmons 2006-07-26 14:26:45 EDT
In Rawhide this still fails but with a different error:

$ java -jar JabRef-2.0.1.jar
Exception in thread "main" java.lang.NullPointerException
   at java.util.Hashtable.put(libgcj.so.7rh)
   at javax.swing.plaf.basic.BasicToolBarUI.setBorderToNonRollover(libgcj.so.7rh)
   at
javax.swing.plaf.basic.BasicToolBarUI$ToolBarContListener.componentAdded(libgcj.so.7rh)
   at java.awt.Container.addImpl(libgcj.so.7rh)
   at javax.swing.JToolBar.addImpl(libgcj.so.7rh)
   at java.awt.Container.add(libgcj.so.7rh)
   at net.sf.jabref.SidePaneComponent.<init>(Unknown Source)
   at net.sf.jabref.imports.MedlineFetcher.<init>(Unknown Source)
   at net.sf.jabref.JabRefFrame.init(Unknown Source)
   at net.sf.jabref.JabRefFrame.<init>(Unknown Source)
   at net.sf.jabref.JabRef.openWindow(Unknown Source)
   at net.sf.jabref.JabRef.<init>(Unknown Source)
   at net.sf.jabref.JabRef.main(Unknown Source)
Comment 2 Thomas Fitzsimmons 2006-08-30 14:04:41 EDT
This problem is caused by one of JabRef's dependencies, Spin, using Sun-private
classes.  GNU Classpath cannot implement undocumented Sun-private classes, so
these references must be eliminated by either rewriting JabRef to not use Spin,
or rewriting Spin to only use standard classes.  Can you file a bug report to
that effect upstream with the JabRef developers?

Note You need to log in before you can comment on or make changes to this bug.