Bug 18708 - Screen chews up inordinate amount of CPU
Summary: Screen chews up inordinate amount of CPU
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: screen   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-09 13:11 UTC by Need Real Name
Modified: 2007-03-27 03:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 15:35:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-09 13:11:14 UTC
Running screen-3.9.4-3 or screen-3.9.5-4 utilizes 95-99% of CPU.

Comment 1 Crutcher Dunnavant 2000-10-10 20:35:55 UTC
Could you give me more info, I can't reproduce.

A good test case would be nice.

Comment 2 Need Real Name 2000-10-11 12:25:10 UTC
Relevant packages:

screen-3.9.4-3
ncurses-4.2-25
utempter-0.5.1-2
glibc-2.1.2-11
kernel-2.2.12-20

Works fine on an IBM ThinkPad 240 (Celeron 300Mhz).

Eats up 99% of CPU time on a SCSI-based, Pentium III 600MHz workstation.

I can provide strace output of both on request.

Comment 3 Crutcher Dunnavant 2000-10-19 15:35:08 UTC
Please, give me some straces then.

*sigh*
Screen is pretty much broke by design,
but it's the only thing that does what it does.


Note You need to log in before you can comment on or make changes to this bug.