Bug 187142 - g++ -frepo not working
g++ -frepo not working
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: 187323 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-03-28 14:19 EST by Jesse Thilo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-04 05:35:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Test case (239 bytes, text/plain)
2006-03-28 14:19 EST, Jesse Thilo
no flags Details

  None (edit)
Description Jesse Thilo 2006-03-28 14:19:21 EST
Description of problem:
g++ with "-frepo" does not appear to generate automatic template instantiations

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. g++ -frepo -c frepo.cc
2. g++ -frepo frepo.o -o frepo
Actual results:
frepo.o: In function `main':frepo.cc:(.text+0x18): undefined reference to
collect2: ld returned 1 exit status

Expected results:
Successful linking; template constructor should have been generated automatically.

Additional info:
Test case compiles and links without -frepo.
Compilation with "-frepo -DREDUNDANT" fails (as expected).
I have this problem on all FC5 machines I've tried (both fresh installations and
updates from FC4).
Comment 1 Jesse Thilo 2006-03-28 14:19:21 EST
Created attachment 126921 [details]
Test case
Comment 2 Jesse Thilo 2006-03-28 14:20:59 EST
Forgot to mention: this worked with FC4.
Comment 3 Jesse Thilo 2006-03-28 22:04:02 EST
I had some more time to play with this.  I installed binutils-
(from FC4 updates) with "rpm -Uvh --oldpackage --nodeps" and the test case does
compile and link successfully, so I've changed this to a binutils bug.  (Oops!)

Except for the fact that binutils- is the relevant component, the
information above (including the procedure for reproducing the problem) remains
the same.
Comment 4 Jakub Jelinek 2006-03-30 02:51:57 EST
*** Bug 187323 has been marked as a duplicate of this bug. ***
Comment 5 Chris Rankin 2006-03-30 03:30:09 EST
I have tried replaced the ld program in FC5 with the version from "vanilla"
2.16.1 binutils:

$ ld --version
GNU ld version 2.16.1
Copyright 2005 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.

and that has fixed my problem (#187323) too.

Note You need to log in before you can comment on or make changes to this bug.