Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 18715 - LPRng won't print this page
LPRng won't print this page
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
http://www.scyld.com/press_releases.html
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 10:52 EDT by Craig Kelley
Modified: 2018-03-07 18:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 12:40:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Postscript output of Netscape, which lprng fails to print on a lpd-enabled HP Laserjet 8000 printer (5.58 KB, application/octet-stream)
2000-10-09 12:40 EDT, Craig Kelley
no flags Details

  None (edit)
Description Craig Kelley 2000-10-09 10:52:41 EDT
I've tried printing this page with RedHat 6.2 and it work great, but LPRng
does not print it (see the attached URL).  I'm sending it to a PostScript
printer (using the *auto* PostScript filter installed by default).  The
machine in question has been upgraded from RedHat 6.2 and I am using the
Netscape installed with 7.0 to send it over.  I'm not sure if the problem
is with Netscape, but it does work from a 6.2 box.
Comment 1 Crutcher Dunnavant 2000-10-09 12:31:39 EDT
Please re-attach the file, It is not here
Comment 2 Craig Kelley 2000-10-09 12:40:00 EDT
Created attachment 3924 [details]
Postscript output of Netscape, which lprng fails to print on a lpd-enabled HP Laserjet 8000 printer
Comment 3 Crutcher Dunnavant 2000-10-11 11:36:47 EDT
ooh, this is goofy.
I cannot find ANY way to get content out of this file.
postscript printers dont understand it raw,
ghostscript uses ps2ps to convert it to almost nothing,
and ghostview displays it as blank.

I looks like the postscript page source is either A) Buggy, or B) Technically
correct, but had tweaked in ways that no one actually supports.

If you can get anything to view/print this postscript file, reopen this bug with
the info, meanwhile, I am gonna close as wontfix
Comment 4 openshift-github-bot 2018-03-07 18:08:36 EST
Commits pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/f3e52f95a9a8f652a8c414bf26f549b91f64cef7
Reorder Groups in Cert Subjects

This is to workaround Bug #18715, which is caused by Golang Crypto's x509
certificate generation ordering Subjects RDN incorrectly *and* GNUTLS'
bug that "fixes" client certs on read with the correct encoding.

To avoid issues until both are fixed we set the correct ordering on our
own...

Signed-off-by: Simo Sorce <simo@redhat.com>

https://github.com/openshift/origin/commit/746e4d3531e8a699193dc45c1f6f8387ed537406
Merge pull request #18837 from simo5/RDNOrder

Automatic merge from submit-queue (batch tested with PRs 18835, 18857, 18641, 18656, 18837).

Reorder groups in cert Subjects

This is to workaround Bug #18715, which is caused by Golang Crypto's x509
certificate generation ordering Subjects RDN incorrectly *and* GNUTLS'
bug that "fixes" client certs on read with the correct encoding.

To avoid issues until both are fixed we set the correct ordering ourself

Fixes #18715
xref https://github.com/golang/go/issues/24254 https://gitlab.com/gnutls/gnutls/issues/403#note_61687722

Note You need to log in before you can comment on or make changes to this bug.