This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187173 - incompatible with perl-Config-General
incompatible with perl-Config-General
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: w3c-markup-validator (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 17:52 EST by Dale Bewley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 11:47:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix for duplicate msg error (928 bytes, patch)
2006-03-28 18:04 EST, Dale Bewley
no flags Details | Diff

  None (edit)
Description Dale Bewley 2006-03-28 17:52:13 EST
Description of problem:
Error on submission of URL to validator

Cannot add named block <msg 1> to hash! Block <msg> occurs more than once.
Turn on -MergeDuplicateBlocks or make sure <msg> occurs only once in the config.
 at /usr/share/w3c-markup-validator/check line 139
BEGIN failed--compilation aborted at /usr/share/w3c-markup-validator/check line 192.

Version-Release number of selected component (if applicable):
 w3c-markup-validator-0.6.7-2
 perl-Config-General-2.31-1.fc5


How reproducible:
 Every time


Steps to Reproduce:
1. Visit http://localhost/w3c-validator/
2. Submit URL for validation.
3.
  
Actual results:
Error.

Expected results:
Parsed results.

Additional info:
I believe there is a new 'check' script that addresses this.
http://dev.w3.org/cvsweb/validator/httpd/cgi-bin/check.diff?r1=1.432.2.10&r2=1.432.2.11
Comment 1 Dale Bewley 2006-03-28 18:04:18 EST
Created attachment 126944 [details]
Fix for duplicate msg error

This seems to fix the problem.
Comment 2 Ville Skyttä 2006-03-29 01:40:23 EST
Yes, that patch fixes the problem, I know because I wrote it :)

However, w3c-markup-validator is no longer (for now, and has been like that for
quite some time) included in Extras for >= FC4 because of issues with SELinux. 
Those are being worked on (bug 182673), but I guess I should consider just
shipping it again even before those are fixed.  The fix is also included in the
latest 0.7.2 upstream version.
Comment 3 Dale Bewley 2006-03-29 11:03:21 EST
Howdy,
Didn't mean to take credit for the patch, I just found a later version of check
and copied what looked to be the minimum to make it work. I was in a hurry too.

I can agree adding SELinux support is a good thing, but some people don't enable
it since it's really still shaking out through the distribution. (me)

However, I'm pretty sure I installed it from Extras in FC4 and FC5.
I hope you can re-roll and release. Thanks

[root@tofu extras]# yum search w3c-markup-validator
...
w3c-markup-validator.noarch              0.6.7-2                extras
Matched from:
w3c-markup-validator

[root@tofu extras]# pwd
/var/cache/yum/extras
[root@tofu extras]# gunzip -c primary.xml.gz|grep w3c-markup
<package
type="rpm"><name>w3c-markup-validator-libs</name><arch>noarch</arch><version
epoch="0" ver="0.6.7" rel="2"/>...
Comment 4 Ville Skyttä 2006-03-29 11:17:18 EST
(In reply to comment #3)
> Didn't mean to take credit for the patch,

...and I didn't mean that you sounded like you would :)

> However, I'm pretty sure I installed it from Extras in FC4 and FC5.

I checked, and it's not in the FE4 repository, but for some reason the old
version has crept in the FE5 one indeed.  I'll roll an update for FE5 then.

Note You need to log in before you can comment on or make changes to this bug.