Bug 187194 - gnome-volume-control crashes occasionally
gnome-volume-control crashes occasionally
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 23:08 EST by Wesley Haines
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: 2.16.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 12:02:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Haines 2006-03-28 23:08:41 EST
Description of the crash:
I double-clicked on the volume control icon on the panel (Volume Applet 2.14.0),
reviewed the
mixer settings, checked and unchecked 'Wave' in Edit -> Preferences, and
closed the window. Volume control crashed.

Steps to reproduce the crash:
1. See above.

Expected Results:
No crash.

How often does this happen?
This has happened about 3 times now since upgrading to GNOME 2.14 and
FC5.


Debugging Information:

Backtrace was generated from '/usr/bin/gnome-volume-control'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its
symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208592720 (LWP 3845)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xbffff402 in __kernel_vsyscall ()
#0  0xbffff402 in __kernel_vsyscall ()
#1  0x47a53a13 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x4d953086 in gnome_init_with_popt_table ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x080501d4 in gnome_volume_control_volume_ask ()
#5  0x0804f909 in gnome_volume_control_track_add_option ()
#6  0x47a9f7b6 in g_source_get_current_time () from
/usr/lib/libglib-2.0.so.0
#7  0x47a9f09d in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#8  0x47aa232f in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
#9  0x47aa26d9 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0x4d58b594 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x0804e11d in main ()

Thread 1 (Thread -1208592720 (LWP 3845)):
#0  0xbffff402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x47a53a13 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x4d953086 in gnome_init_with_popt_table ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x080501d4 in gnome_volume_control_volume_ask ()
No symbol table info available.
#5  0x0804f909 in gnome_volume_control_track_add_option ()
No symbol table info available.
#6  0x47a9f7b6 in g_source_get_current_time () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x47a9f09d in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x47aa232f in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x47aa26d9 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#10 0x4d58b594 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#11 0x0804e11d in main ()
No symbol table info available.
Comment 1 Bastien Nocera 2007-04-19 11:25:41 EDT
Do you still see the problem in more recent versions? If so, could you please
gather a backtrace with the -debuginfo package for gnome-media installed?

See the instructions at:
http://fedoraproject.org/wiki/StackTraces
Comment 2 Wesley Haines 2007-04-19 12:02:50 EDT
I have not had this problem with FC6 (GNOME 2.16.0.1). I meant to close this bug
since then. Thanks!

Marking as closed.

Note You need to log in before you can comment on or make changes to this bug.