Bug 187207 - missing charsets in fontset warning after upgrading
missing charsets in fontset warning after upgrading
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 03:16 EST by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 21.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-02 19:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-03-29 03:16:13 EST
Description of problem:
After upgrading to FC5 and FE5, xemacs is giving me a warning about
missing charsets in fontset whenever it is started in a utf8 locale.

Version-Release number of selected component (if applicable):
xemacs-21.4.19-3.fc5
xemacs-sumo-20051208-2

How reproducible:
every time in UTF-8 locale

Steps to Reproduce:
1. run "xemacs -vanilla"
  
Actual results:
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset

Expected results:
No warnings.

Additional info:
This seems to break things like ediff that use a separate frame.
Comment 1 Jens Petersen 2006-03-29 03:39:53 EST
This was already implied, but I forgot to add that the warning doesn't
seem to occur when xemacs is run in a legacy native locale.

Also I have the following fonts installed:
bitmap-fonts-0.3-5.1
bitstream-vera-fonts-1.10-5.1
fonts-arabic-1.5-5
fonts-bengali-1.10-2.1
fonts-chinese-3.02-4.1
fonts-gujarati-1.10-2.1
fonts-hebrew-0.100-4.1
fonts-hindi-1.10-2.1
fonts-japanese-0.20050222-11.1
fonts-korean-1.0.11-9.1
fonts-punjabi-1.10-2.1
fonts-tamil-1.10-2.1
xorg-x11-fonts-75dpi-7.0-3
xorg-x11-fonts-ISO8859-1-100dpi-7.0-3
xorg-x11-fonts-ISO8859-1-75dpi-7.0-3
xorg-x11-fonts-Type1-7.0-3
xorg-x11-fonts-base-7.0-3
xorg-x11-fonts-misc-7.0-3
Comment 2 Ville Skyttä 2006-03-29 10:36:41 EST
(In reply to comment #0)
> After upgrading to FC5 and FE5, xemacs is giving me a warning about
> missing charsets in fontset whenever it is started in a utf8 locale.

Curious.  I saw that warning when I was following Rawhide during the FC5 test
releases, but it just disappeared here after installing FC5 final from scratch.
 Did you install from scratch or upgrade from something earlier?

My $LANG is en_US.UTF-8 and the font packages I have installed are:

bitmap-fonts-0.3-5.1
bitstream-vera-fonts-1.10-5.1
ghostscript-fonts-5.50-13.1
urw-fonts-2.3-6.1
xorg-x11-fonts-100dpi-7.0-3
xorg-x11-fonts-75dpi-7.0-3
xorg-x11-fonts-base-7.0-3
xorg-x11-fonts-ISO8859-1-100dpi-7.0-3
xorg-x11-fonts-ISO8859-1-75dpi-7.0-3
xorg-x11-fonts-misc-7.0-3
xorg-x11-fonts-truetype-7.0-3
xorg-x11-fonts-Type1-7.0-3

Not everything seems to be ok with fonts though; non-ASCII characters such as
"ä" from my surname are larger in buffers than ASCII ones.
Comment 3 Ville Skyttä 2006-03-29 12:36:55 EST
Could you try the packages built with gcc 3.2 at
http://koti.welho.com/vskytta/xemacs/ and let me know if they make any
difference?   At least they fix the non-ASCII-chars-are-bigger-than-ASCII
problem for me.
Comment 4 Jens Petersen 2006-03-31 00:50:25 EST
I'm afraid it is the same for me with your 21.4.19-4 package on my upgraded
i386 box.
Comment 5 Ville Skyttä 2006-03-31 01:25:03 EST
Do you see the other symptoms mentioned in bug 180284: does xfontsel print the
warning too, and does xfs consume all cpu for a while when starting up
xemacs/xfontsel?
Comment 6 Ville Skyttä 2007-09-01 16:34:17 EDT
Jens, have you seen any of these issues with 21.5.x or later than FC5?
Comment 7 Jens Petersen 2007-09-02 19:36:57 EDT
No I think this is fixed now - thanks.

Note You need to log in before you can comment on or make changes to this bug.