Bug 187247 - Sed hangs during Dovecot-lda configure
Sed hangs during Dovecot-lda configure
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sed (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 10:22 EST by Tomi Hakala
Modified: 2015-05-04 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 03:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomi Hakala 2006-03-29 10:22:03 EST
Description of problem:

I cannot compile Dovecot-LDA source on RHEL 4 x86_64 because sed seem to hang
during "configure".

Configure output looks like this

./configure --prefix=/opt/dovecot --with-dovecot=/usr/local/src/dovecot
[...cut...]
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking for library containing regcomp... none required
checking rxposix.h usability... no
checking rxposix.h presence... no
checking for rxposix.h... no
configure: creating ./config.status
config.status: creating Makefile

And there it hangs, if I look running processes with "ps axuw" I see:

USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root     16433  0.0  0.0  3804 1816 pts/0    S+   18:14   0:00 sed -f
./confstatl16402/subs-2.sed
root     16434 99.9  0.0  2748  708 pts/0    R+   18:14   1:40 sed -f
./confstatl16402/subs-3.sed


Version-Release number of selected component (if applicable):

sed --version
GNU sed version 4.1.2

How reproducible:

Always

Steps to Reproduce:
1. Download Dovecot CVS code
cvs -d :pserver:anonymous@dovecot.org:/home/cvs login
(empty password)
cvs -d :pserver:anonymous@dovecot.org:/home/cvs co dovecot

2. Run autogen.sh, configure and compile

3. Download Dovecot-LDA code
cvs -d :pserver:anonymous@dovecot.org:/home/cvs co dovecot-lda

4. Run autogen.sh and configure

Actual results:

Hang

Expected results:

Configure script should finish

Additional info:
Comment 1 Petr Machata 2006-03-29 15:57:56 EST
Strange thing. It shouldn't hang *after* "creating Makefile" gets written, as
sed -f gets issued only before anything gets actually generated. Could you
please send me your configure, and maybe also config.status? (Just attach them
here at bugzilla.) Thanks...

Note You need to log in before you can comment on or make changes to this bug.