Bug 187272 - K3B and other DVD burning programs that use growisofs fails to work
K3B and other DVD burning programs that use growisofs fails to work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
5
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 13:13 EST by Joseph Apuzzo
Modified: 2008-05-06 11:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Apuzzo 2006-03-29 13:13:22 EST
Description of problem:
When useing K3B to burn a DVD-R I get the following error:

Error: :-( unable to O_EXCL /dev/hdb: someone was in time to remount?

This occurs in GNOME,KDE.XFCE4 etc.
K3B worked on this system when it was FC4 with no issues.
I formated the drive and installed FC5 from DVD, I did not upgrade.

Version-Release number of selected component (if applicable):
dvd+rw-tools-6.1-0.FC5.1

How reproducible:
Start K3B and try to create a DVD-R on the fly

Steps to Reproduce:
1. Start any FC5 app that can create a DVD
2. Tell app to create the DVD ( will use growisofs under the covers )
3. growisofs will fail
  
Actual results:
Error: :-( unable to O_EXCL /dev/hdb: someone was in time to remount?

Expected results:
Create a DVD-R as it did in FC4

Additional info:
Searched the web for information, there was none
Searched bugzilla.redhat.com to make sure this is not a dupe, ans did not find one.
Comment 1 E Mair 2006-04-03 21:26:44 EDT
http://fy.chalmers.se/~appro/linux/DVD+RW/tools/

This page, linked from bug #187275 , says there is an issue with growisofs 6.0
and "newer kernels". Did FC5's growisofs 6.1 leave out a workaround, or is this
an upstream problem?

FWIW, I can burn DVDs if I run k3b as root. As a regular user I get the symptoms
reported here.
Comment 2 E Mair 2006-04-05 10:35:54 EDT
FWIW, the workaround suggested on the site mentioned above, "ulimit -l
unlimited", doesn't help.
Comment 3 Harald Hoyer 2006-04-18 09:12:35 EDT
best to configure /etc/security/limits.conf like:
*               hard    memlock         unlimited
*               soft    memlock         32

Comment 5 E Mair 2006-04-19 13:46:53 EDT
See comment #15 to bug #187275
Comment 6 Harald Hoyer 2007-06-21 06:57:16 EDT
Disable automounting of removable media (gnome-volume-properties)

Also set the buffer in k3b to a lower amount
Comment 7 petrosyan 2008-03-11 12:42:17 EDT
Fedora Core 5 is no longer maintained. Is this bug still present in Fedora 7 or
Fedora 8?
Comment 8 Bug Zapper 2008-04-03 22:21:20 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 9 Bug Zapper 2008-05-06 11:41:52 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.