Bug 187286 - host(1) repeats output of aliases
host(1) repeats output of aliases
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 14:54 EST by Olle Liljenzin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 04:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olle Liljenzin 2006-03-29 14:54:27 EST
Description of problem:
Output from the host command is repeated if the argument is a CNAME.

Version-Release number of selected component (if applicable):
bind-utils-9.3.1-18.FC4

How reproducible:
Always

Steps to Reproduce:
1. host www
  
Actual results:
www.liljenzin.se is an alias for slusk.liljenzin.se.
slusk.liljenzin.se has address 192.168.0.2
www.liljenzin.se is an alias for slusk.liljenzin.se.
www.liljenzin.se is an alias for slusk.liljenzin.se.


Expected results:
www.liljenzin.se is an alias for slusk.liljenzin.se.
slusk.liljenzin.se has address 192.168.0.2

Additional info:
Not the most important bug I have seen, but the output doesn't look like in old
releases.
Comment 1 Jason Vas Dias 2006-03-29 15:54:14 EST
Yes, this is because by default, 
 $ host $DN 
makes 3 queries for name argument $DN:
  A?    $DN 
  AAAA? $DN 
  MX?   $DN
and an alias is returned for each one,
so the alias line is repeated three times.
Doing:
 $ host -t a $DN
will return only one 'alias' line.
I suppose potentially one could define 
records for a name that is also a CNAME,
though this would be bad practice - hence,
I don't think this is a bug.
Comment 2 Olle Liljenzin 2006-03-30 03:40:11 EST
Quoted from BIND 9 Administrator Reference Manual:

"For a given domain, if there is both a CNAME record and an MX record, the MX
record is in error, and will be ignored. Instead, the mail will be delivered to
the server specified in the MX record pointed to by the CNAME."

And how could a CNAME record resolve to different results in the case of A or
AAAA queries?
Comment 3 Jason Vas Dias 2006-03-30 12:48:41 EST
OK, on second thoughts, I guess what host SHOULD be doing is if it finds a 
CNAME for ANY of its default A, AAAA, or MX queries, then it should emit
one 'alias' line, then abort and restart the queries for the canonical name.

Comment 4 Jason Vas Dias 2006-03-30 12:54:28 EST
Looks like this bug is already noted upstream and fixed in the (unavailable) 
bind-9.3.3alpha release:
 1995.  [bug]  	'host' was reporting multiple "is an alias" messages. [RT #15702]
I'll see what I can do to get this fixed.
Comment 5 Jason Vas Dias 2006-03-30 19:15:40 EST
This bug is now fixed with bind-9.3.1-20.FC4, bind-9.3.2-16.FC5, and 
bind-9.3.2-16.FC6, shortly to be submitted to FC Updates/Testing.
The FC-4 version is available for download at:
   http://people.redhat.com/~jvdias/bind/FC4/9.3.1-20.FC4 
Please try out this version and let me know of any issues.
host(1) will now use any CNAME returned from the A lookup as the name
for the AAAA and MX lookups, avoiding redundant 'is an alias for' messages.
Comment 6 Olle Liljenzin 2006-03-31 01:57:36 EST
I installed bind-9.3.1-20.FC4 and the reported problem is fixed as far as I can
see. Thanks!
Comment 7 Fedora Update System 2006-04-04 12:11:26 EDT
bind-9.3.2-16.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Fedora Update System 2006-04-04 12:12:43 EDT
bind-9.3.1-20.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 9 Fedora Update System 2006-04-17 11:42:30 EDT
bind-9.3.1-20.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 10 Fedora Update System 2006-04-17 11:42:47 EDT
bind-9.3.2-16.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.