Bug 187331 - Error: Cannot find a valid baseurl for repo: core
Error: Cannot find a valid baseurl for repo: core
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 23:50 EST by Peter Blomgren
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Blomgren 2006-03-29 23:50:25 EST
Description of problem:

Cannot find a valid baseurl for repo: core

Version-Release number of selected component (if applicable):

2.6.0-1

How reproducible:

Always.

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:

Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/4]
Cannot find a valid baseurl for repo: core
Error: Cannot find a valid baseurl for repo: core


Expected results:

Connection to repositories...

Additional info:

This is happening on a system upgraded from FC4 using the DVD image.  The
"funny" thing is that 2 other upgraded systems, and one fresh install works
fine; and all the config files look the same to me...

SELINUX=permissive
SELINUXTYPE=targeted
SETLOCALDEFS=0

=== Contents of /etc/yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=fedora-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
http_caching=packages


=== Contents of /etc/yum.repos.d/fedora-core.repo
[core]
name=Fedora Core $releasever - $basearch
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/os/
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-core-$releasever
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[core-debuginfo]
name=Fedora Core $releasever - $basearch - Debug
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/debug/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[core-source]
name=Fedora Core $releasever - Source
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/source/SRPMS/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY
Comment 1 Michael Godfrey 2006-03-30 12:35:16 EST
I have a similar problem.  I found that the failures started
after the updates that were available on 28 March. nscd is the
only one that seemed related to this problem.  Anyhow, I found
that on system where yum fails, wget, using the URL from the 
ym.repos.d files, also fails with a "no find" on the IP address
(such as "download.fedora.redhat.com").  Firefox resolves that
URL, and substiuting the numeric IP also causes yum to work.

Of 4 machines on the same subnetwork, 3 fail and one works after
the same update set on 28 March.
Comment 2 Michael Godfrey 2006-03-30 13:23:42 EST
One correction to my comment above:  The systems were running
FC4 with all current updates, not FC5.  So, this bug report
should also be considered for FC4.

Michael
Comment 3 Peter Blomgren 2006-03-30 14:33:09 EST
OK, let me "Me three!" on my own bug...  After seeing Michael's comments, I
checked on the status of my remaining FC4 system.  Indeed, it displays the same
problem; and it started after the updates on March 28:

 Packages Updated:
    glibc-devel.i386 2.3.6-3
    mtr-gtk.i386 2:0.71-0.FC4.1
    perl.i386 3:5.8.6-24
    glibc-headers.i386 2.3.6-3
    glibc-profile.i386 2.3.6-3
    glibc-utils.i386 2.3.6-3
    glibc-common.i386 2.3.6-3
    glibc.i686 2.3.6-3
    nscd.i386 2.3.6-3
    mtr.i386 2:0.71-0.FC4.1

... and, yeah, it's the address resolution that fails; not yum per se.
Comment 4 Peter Blomgren 2006-03-30 14:57:13 EST
See glibc bugs 186592, and 187320

Minimum necessary modification:

in /etc/nsswitch.conf

change the line
hosts:      files nisplus dns

to
hosts:      files dns nisplus

... and the problems go away!
Comment 5 Michael Godfrey 2006-03-30 15:58:26 EST
You are right. Just figured that out.  It is unclear how/when nsswitch.conf
got changed.  I am looking into that.

Also, depending on configureation, hosts: files dns
is safe.
Comment 6 Robert Thomas 2006-04-11 10:04:33 EDT
This problem also comes up if you have a http_proxy defined in the environment.
Even if the http_proxy host works fine with a browser. Gives a 502 error. The
solution of course is to "unset http_proxy".
Comment 7 Jeremy Katz 2006-04-19 16:44:47 EDT

*** This bug has been marked as a duplicate of 186592 ***

Note You need to log in before you can comment on or make changes to this bug.