Bug 187368 - Yum fails with dependency loop after upgrade from FC3 -> FC4
Summary: Yum fails with dependency loop after upgrade from FC3 -> FC4
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 187367 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-30 16:00 UTC by Rick Wanner
Modified: 2014-01-21 22:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 22:51:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rick Wanner 2006-03-30 16:00:29 UTC
Description of problem:
After upgrading from FC3 to FC4 yum fails with a dependency error 
whenever "yum update" is run.

> /root/bin/yum_update >> /root/log/yum_update.log >&1 
Error: Missing Dependency: libgcj34 >= 3.4.0-1 is needed by package xerces-j
Error: Missing Dependency: libgcj.so.5 is needed by package xerces-j


Version-Release number of selected component (if applicable):
yum-2.4.1-1.fc4

How reproducible:
Consistently reproducible

Steps to Reproduce:
1. run "yum update"
  
Actual results:
Error: Missing Dependency: libgcj34 >= 3.4.0-1 is needed by package xerces-j
Error: Missing Dependency: libgcj.so.5 is needed by package xerces-j


Expected results:
That yum will resolve the dependency and update the system.

Additional info:
tail end of screen output:

---> Package ruby.i386 0:1.8.4-1.fc4 set to be updated
---> Downloading header for ruby-libs to pack into transaction set.
ruby-libs-1.8.4-1.fc4.i38 100% |=========================|  69 kB    00:00
---> Package ruby-libs.i386 0:1.8.4-1.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libgcj34 >= 3.4.0-1 for package: xerces-j
--> Processing Dependency: libgcj.so.5 for package: xerces-j
--> Finished Dependency Resolution
Error: Missing Dependency: libgcj34 >= 3.4.0-1 is needed by package xerces-j
Error: Missing Dependency: libgcj.so.5 is needed by package xerces-j

Comment 1 Rick Wanner 2006-03-30 16:04:35 UTC
Sorry, I accidentally created a dup.  Please close.

Comment 2 Ignacio Vazquez-Abrams 2006-03-30 16:05:07 UTC
*** Bug 187367 has been marked as a duplicate of this bug. ***

Comment 3 Ignacio Vazquez-Abrams 2006-03-30 16:10:30 UTC
xerces-j isn't part of FC3 so I'm unsure how this is a Fedora problem.

Comment 4 Rick Wanner 2006-03-30 21:50:25 UTC
Then where did it come from? The only non-standard software on this box is big
brother (bb) and that was installed separately, not installed with yum.

All I know is that yum worked while this was a FC3 box, but it doesn't now that
it is an FC4 box.

Comment 5 Rick Wanner 2006-03-30 22:51:01 UTC
Go ahead and close.  I deleted a bunch of rpm's including xerces-j and now yum
works.  Hope I don't need any of that stuff.


Note You need to log in before you can comment on or make changes to this bug.