Bug 187395 - rhpl dependencies
rhpl dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 191353 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 13:15 EST by Wil Harris
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-31 13:31:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wil Harris 2006-03-30 13:15:16 EST
Description of problem:
rhpl requires wireless-tools. It doesn't seem logical that a package of modules
for other programs would require wireless tools to install (pirut for example).
It also seems that packages that depend on rhpl do not have the dependencies set
right to require it, but of course will not run if its removed.

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 rhpl                    i386       0.185-1          core              247 k
Installing for dependencies:
 wireless-tools          i386       1:28-0.pre13.5.1  core              110 k

Transaction Summary
=============================================================================


Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 wireless-tools          i386       1:28-0.pre13.5.1  installed         231 k
Removing for dependencies:
 rhpl                    i386       0.185-1          installed         910 k

Transaction Summary
=============================================================================

Version-Release number of selected component (if applicable):
0.185-1

How reproducible:
everytime

Steps to Reproduce:
1. yum remove rhpl
2. yum install rhpl
3.
  
Actual results:
yum will grab wireless tools to satisfy dependencies.

Expected results:
rhpl to require python, but not wireless tools...what does wireless-tools have
to do with this package?

Additional info:

[root@taz ~]# yum search rhpl
Searching Packages:
Setting up repositories
core                                                                 [1/3]
updates                                                              [2/3]
extras                                                               [3/3]
Reading repository metadata in from local files


rhpl.i386                                0.185-1                core
Matched from:
rhpl
The rhpl package contains Python code used by programs in Red Hat Linux.
[root@taz ~]# rpm -qi rhpl
package rhpl is not installed
[root@taz ~]# yum install rhpl
Setting up Install Process
Setting up repositories
core                                                                 [1/3]
updates                                                              [2/3]
extras                                                               [3/3]
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for rhpl to pack into transaction set.
ftp://redhat.taygeta.com/pub/RedHat/fedora/core/5/i386/os/Fedora/RPMS/rhpl-0.185-1.i386.rpm:
[Errno 4] IOError: [Errno ftp error] 550 os: No such file or directory
Trying other mirror.
rhpl-0.185-1.i386.rpm     100% |=========================|  45 kB    00:00
---> Package rhpl.i386 0:0.185-1 set to be updated
--> Running transaction check
--> Processing Dependency: libiw.so.28 for package: rhpl
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for wireless-tools to pack into transaction set.
wireless-tools-28-0.pre13 100% |=========================| 8.9 kB    00:00
---> Package wireless-tools.i386 1:28-0.pre13.5.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 rhpl                    i386       0.185-1          core              247 k
Installing for dependencies:
 wireless-tools          i386       1:28-0.pre13.5.1  core              110 k

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 356 k
Downloading Packages:
(1/2): rhpl-0.185-1.i386. 100% |=========================| 247 kB    00:02
(2/2): wireless-tools-28- 100% |=========================| 110 kB    00:01
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: wireless-tools               ######################### [1/2]
  Installing: rhpl                         ######################### [2/2]

Installed: rhpl.i386 0:0.185-1
Dependency Installed: wireless-tools.i386 1:28-0.pre13.5.1
Complete!
[root@taz ~]# rpm -qi rhpl
Name        : rhpl                         Relocations: (not relocatable)
Version     : 0.185                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Thu 02 Mar 2006 08:55:09
PM EST
Install Date: Thu 30 Mar 2006 12:52:21 PM EST      Build Host:
tweety.build.redhat.com
Group       : System Environment/Libraries   Source RPM: rhpl-0.185-1.src.rpm
Size        : 931867                           License: GPL
Signature   : DSA/SHA1, Mon 06 Mar 2006 05:11:41 PM EST, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Library of python code used by programs in Red Hat Linux
Description :
The rhpl package contains Python code used by programs in Red Hat Linux.
[root@taz ~]# yum remove wireless-tools
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package wireless-tools.i386 1:28-0.pre13.5.1 set to be erased
--> Running transaction check
Setting up repositories
core                                                                 [1/3]
updates                                                              [2/3]
extras                                                               [3/3]
Reading repository metadata in from local files
--> Processing Dependency: libiw.so.28 for package: rhpl
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package rhpl.i386 0:0.185-1 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 wireless-tools          i386       1:28-0.pre13.5.1  installed         231 k
Removing for dependencies:
 rhpl                    i386       0.185-1          installed         910 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       2 Package(s)
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Removing  : wireless-tools               ######################### [1/2]
  Removing  : rhpl                         ######################### [2/2]

Removed: wireless-tools.i386 1:28-0.pre13.5.1
Dependency Removed: rhpl.i386 0:0.185-1
Complete!
[root@taz ~]# yum install rhpl
Setting up Install Process
Setting up repositories
core                                                                 [1/3]
updates                                                              [2/3]
extras                                                               [3/3]
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package rhpl.i386 0:0.185-1 set to be updated
--> Running transaction check
--> Processing Dependency: libiw.so.28 for package: rhpl
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package wireless-tools.i386 1:28-0.pre13.5.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 rhpl                    i386       0.185-1          core              247 k
Installing for dependencies:
 wireless-tools          i386       1:28-0.pre13.5.1  core              110 k

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 356 k
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: wireless-tools               ######################### [1/2]
  Installing: rhpl                         ######################### [2/2]

Installed: rhpl.i386 0:0.185-1
Dependency Installed: wireless-tools.i386 1:28-0.pre13.5.1
Complete!
[root@taz ~]#
Comment 1 Chris Lumens 2006-03-31 13:31:52 EST
rhpl requires /lib/libiw.so, which is a library for querying wireless network
devices.  This is used by the ethtool extension provided in rhpl.
Comment 2 Chris Lumens 2006-05-11 10:38:51 EDT
*** Bug 191353 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.