Bug 187406 - Permissive SElinux blocks wifi in NetworkManager on resume
Permissive SElinux blocks wifi in NetworkManager on resume
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2006-03-30 14:06 EST by Simon Goodall
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-28 16:03:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/messages chunk (42.42 KB, text/plain)
2006-03-30 15:38 EST, Simon Goodall
no flags Details

  None (edit)
Description Simon Goodall 2006-03-30 14:06:40 EST
Description of problem:
When I suspend and resume selinux is blocking NetworkManager from making an
I installed fc5 with selinux disabled and there was no problem. I have since
tried the permissive setting (which I am currently using) and have come across
this problem. Rebooting and NM works fine again. Suspend/Resume and NM cannot
associate with the wifi, although it seems to get a list of available nets.
Pluging a net cable allows wired network access.
I tried disabling selinux service protection for NM and restarting the NM
service, but this still did not allow it to start.
I then tried switching to the enforced mode and NM started working again.
I have been able to suspend and resume in enforced mode with NM working ok
My wifi uses wep128

Version-Release number of selected component (if applicable):



How reproducible:

Steps to Reproduce:
1. Set SElinux to permissive
2. Suspend machine
3. Resume machine
4. Attempt to connect to a wireless net
Actual results:
Wireless net access blocked

Expected results:
Associate with requested wifi net

Additional info:
Comment 1 Daniel Walsh 2006-03-30 14:49:19 EST
I think you have a red herring here.  But please submit the AVC messages from
Comment 2 Simon Goodall 2006-03-30 15:38:54 EST
Created attachment 127073 [details]
/var/log/messages chunk

Relevant chunk of /var/log/messages from suspend/resume to eth1 failure
Comment 3 Daniel Walsh 2006-03-30 16:36:50 EST
Any idea what process is running as mono_t?
Comment 4 Daniel Walsh 2006-03-30 16:48:29 EST
Chris do you have any ideas?
Comment 5 Simon Goodall 2006-03-31 03:00:56 EST
mono_t is probably from beagled. POssible from banshee, but I don't think that
was running then.
Comment 7 Daniel Walsh 2006-05-09 16:15:17 EDT
Fixed in selinux-policy-2.2.38-1.FC5.
Comment 8 Daniel Walsh 2007-03-28 16:03:46 EDT
Closing bugs

Note You need to log in before you can comment on or make changes to this bug.