Bug 187426 - dvddecrypt no longer see dvd drives now gnome-mount replaces fstab
dvddecrypt no longer see dvd drives now gnome-mount replaces fstab
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 15:47 EST by Mark D Keith
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 16:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark D Keith 2006-03-30 15:47:10 EST
Distribution: Fedora Core release 5 (Bordeaux)
Package: gnome-mount
Severity: Normal
Version: GNOME2.14.0 unspecified
Gnome-Distributor: Red Hat, Inc
Synopsis: dvddecrypt no longer see dvd drives now gnome-mount replaces fstab
Bugzilla-Product: gnome-mount
Bugzilla-Component: programs
Bugzilla-Version: unspecified
Description:
Description of Problem:

With movie dvd mounted, dvddecrypt run via wine no longer sees any
drives.  worked fine on the FC4

Get the following message

I 14:56:27 DVD Decrypter Version 3.5.4.0 started!
I 14:56:27 Microsoft Windows XP Professional (5.1, Build 2600 : Service
Pack 2)
I 14:56:27 Initialising SPTI...
I 14:56:27 Searching for SCSI / ATAPI devices...
W 14:56:27 No devices detected!


Steps to reproduce the problem:
1. Install Wine
2. Install DVDDecrypt via wine
3. Insert DVD movie to decrypt
4. Run DVDDecrypt

Actual Results:

I 14:56:27 DVD Decrypter Version 3.5.4.0 started!
I 14:56:27 Microsoft Windows XP Professional (5.1, Build 2600 : Service
Pack 2)
I 14:56:27 Initialising SPTI...
I 14:56:27 Searching for SCSI / ATAPI devices...
W 14:56:27 No devices detected!


Expected Results:

For it see the drive with the movie and be able to decrypt iy

How often does this happen?

Everytime

Additional Information:

Also tried making old dirs in /media/  and entries for the dvd readers
from fstab of old FC4 installation

Fedora Core 5, kernel-2.6.15-1.2054_FC5
gnome-mount-0.4-5
wine-0.9.10-2.fc5
DVD Decrypter Version 3.5.4.0
Comment 1 John (J5) Palmieri 2006-04-17 16:18:50 EDT
Looks like wine is looking at fstab (it needs to look at mtab for mounted
volumes).  If it is working with unmounted drives it needs to be either HAL
aware or get drive info from the kernel. /etc/fstab is not a canonical place to
find drive information on modern dynamic systems.  Please file this upstream
with Wine.
Comment 2 Moritz Barsnick 2006-06-21 04:34:39 EDT
Mark,

a workaround or perhaps the proper way to go (works for me) may be to configure 
Wine's drive X: (or whatever) to point to the DVD's mount point /media/
<MEDIUMNAME>. Either using winecfg, or by
ln -sf /media/<MEDIUMNAME> ~/.wine/dosdevices/x:

Problem: The mount point changes with every DVD. Perhaps there is a workaround 
someone can point me to where multiple mountpoints or automatic symbolic links 
(/media/DVD -> /media/<MEDIUMNAME>) are created.

I actually did not modify fstab for Wine+DVD Decrypter at all, despite some 
instructions telling you so. I had found an instruction which does exactly the 
above and seems a little bit easier (and can be done fully as non-root :->).

Also don't forget to execute DVDDecrypter within Wine as "WinNT 4.0". :)

Sorry for disturbing a closed bug report,
Moritz

Note You need to log in before you can comment on or make changes to this bug.