Bug 18744 - Oracle 8.0.5 will not install on 7.0
Oracle 8.0.5 will not install on 7.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 17:14 EDT by Steve Dixon
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-11 12:50:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The oratab.sh script that is run to create /etc/oratab. (4.54 KB, text/plain)
2000-10-11 11:40 EDT, Steve Dixon
no flags Details

  None (edit)
Description Steve Dixon 2000-10-09 17:14:33 EDT
At the beginning of the install the oratab.sh file should be run to get the
installation parameters going.  Basically it checks to see if the oracle
user is in the dba group which I added and then put oracle in the group. 
I've checked and re-checked and the oracle user is in the dba group.  Here
is the output from the script.  I also have all of the errata for 7.0 up to
this date, including the glibc update that came out today.

[root@vortex orainst]# oratab.sh

*************************************************************************
Following conditions should be met to run this script successfully.
1. Needs root permission to run this script.
2. Need to set ORACLE_OWNER enviornment variable to the user who
   installs oracle product.
3. This ORACLE_OWNER should be part of group "dba".

If any of these conditions are not met, please re-run after satisfying
these conditions.
*************************************************************************
Is it OK to continue (Y/N)? [Y]: y

The ORACLE_OWNER is set as:  oracle
Are these settings correct (Y/N)? [Y]: y

Checking for "oracle" user id...
./oratab.sh: 0: command not found

The user "oracle" should be in "dba" group.
Please add user "oracle" to group "dba" and re-run the oratab.sh script.
[root@vortex orainst]#
Comment 1 Jakub Jelinek 2000-10-11 04:13:52 EDT
Can you please run sh -x ./oratab.sh and send me a copy of oratab.sh so that
it is clear what's going on?
The
./oratab.sh: 0: command not found
message looks like either something is broken in the shell script, or some
environment variable is not set as it should have been.
Comment 2 Steve Dixon 2000-10-11 11:40:35 EDT
Created attachment 4064 [details]
The oratab.sh script that is run to create /etc/oratab.
Comment 3 Steve Dixon 2000-10-11 11:44:20 EDT
The only environment variable that needs to be set at this point is
ORACLE_OWNER=oracle, which is for root so the script can run.  Here is the
output from sh -x oratab.sh:

[root@vortex orainst]# sh -x oratab.sh
+ CHOWN=/bin/chown
+ CHGRP=/bin/chgrp
+ GROUPS=/usr/bin/groups
+ GROUP=dba
+ GROUP_LOC=/etc/group
+ PASSWD_LOC=/etc/passwd
+ ORATAB=/etc/oratab
+ echo '\c'
+ grep c
+ N=-n
+ echo ''

+ echo
'*************************************************************************'
*************************************************************************
+ echo 'Following conditions should be met to run this script successfully.'
Following conditions should be met to run this script successfully.
+ echo '1. Needs root permission to run this script.'
1. Needs root permission to run this script.
+ echo '2. Need to set ORACLE_OWNER enviornment variable to the user who'
2. Need to set ORACLE_OWNER enviornment variable to the user who
+ echo '   installs oracle product.'
   installs oracle product.
+ echo '3. This ORACLE_OWNER should be part of group "dba".'
3. This ORACLE_OWNER should be part of group "dba".
+ echo ''

+ echo 'If any of these conditions are not met, please re-run after satisfying'
If any of these conditions are not met, please re-run after satisfying
+ echo 'these conditions.'
these conditions.
+ echo
'*************************************************************************'
*************************************************************************
+ DEFLT=Y
+ echo -n 'Is it OK to continue (Y/N)? [Y]: '
Is it OK to continue (Y/N)? [Y]: + RDVAR=Y
+ read RDVAR
y
+ ANSWER=y
++ /bin/ls -l /tmp/fil580
++ awk '{print $3}'
+ INAME=root
+ rm -f /tmp/fil580
+ DEFLT=Y
+ echo ''

+ echo 'The ORACLE_OWNER is set as:  oracle'
The ORACLE_OWNER is set as:  oracle
+ echo -n 'Are these settings correct (Y/N)? [Y]: '
Are these settings correct (Y/N)? [Y]: + RDVAR=Y
+ read RDVAR
y
+ ANSWER=y
+ echo ''

+ echo 'Checking for "oracle" user id...'
+ tee -a
Checking for "oracle" user id...
++ grep '^oracle:' /etc/passwd
+ PW_ENTRY=oracle:x:501:501::/home/oracle:/bin/bash
++ 0 oracle
oratab.sh: 0: command not found
+ ALL_GROUPS=
+ OWNER_IN_GROUP=false
+ '[' false = false ']'
+ echo ''

+ echo 'The user "oracle" should be in "dba" group.'
The user "oracle" should be in "dba" group.
+ echo 'Please add user "oracle" to group "dba" and re-run the oratab.sh
script.'
Please add user "oracle" to group "dba" and re-run the oratab.sh script.
+ exit 1
[root@vortex orainst]# 
Comment 4 Jakub Jelinek 2000-10-11 12:10:44 EDT
Ok, this is actually not related to glibc at all, the script is broken
with respect to bash2, which is now the default /bin/sh in 7.0.
Quoting man bash:
       GROUPS An  array  variable containing the list of groups of which the current user is a member.  Assignments
              to GROUPS have no effect and are silently discarded.  If GROUPS is unset, it loses its special  prop-
              erties, even if it is subsequently reset.
and this script sets GROUPS to /usr/bin/groups and then tries to execute that
variable.
You should fix that script if you want to run it:
either add
unset GROUPS
before GROUPS=/usr/bin/groups line, or perl -pi -e 's/GROUPS/GRPS/' oratab.sh
Comment 5 Steve Dixon 2000-10-11 12:35:51 EDT
I was sure what it was related to since it was oracles scripts and not my own. 
Also, this is just the tip.  There is more that does not work.  But, i'll get to
that in a few minutes as soon as I fix the script.
Comment 6 Steve Dixon 2000-10-11 12:36:46 EDT
Excuse me, I wasn't sure.
Comment 7 Steve Dixon 2000-10-11 12:50:00 EDT
This is the error that pops up during a normal 8.0.5 install w/everything except
the documentation.  It doesn't quite finish the install.

x x Error during action 'Making Oracle Intelligent Agent (target=install)'.x x
x x                                                                        x x
x xCommand:  make -f ins_oemagent.mk install                               x x
x x                                                                        x x
x xchmod 755 /u01/app/oracle/product/8.0.5/bin                             x x
x xBuilding client shared library libclntsh.so ...                         x x
x xCall script /u01/app/oracle/product/8.0.5/bin/genclntsh ...             x x
x x/u01/app/oracle/product/8.0.5/bin/genclntsh                             x x
x xBuilt /u01/app/oracle/product/8.0.5/lib/libclntsh.so ... DONE           x x
x xcc -L/u01/app/oracle/product/8.0.5/lib/ -                               x x
x xL/u01/app/oracle/product/8.0.5/lib/ -                                   x x
x xL/u01/app/oracle/product/8.0.5/rdbms/lib  -                             x x
x xL/u01/app/oracle/product/8.0.5/network/lib   -o dbsnmp                  x x
x x/u01/app/oracle/product/8.0.5/network/lib/s0nmi.o                       x x
x x/u01/app/oracle/product/8.0.5/network/lib/waat0.o -lnmi -lnms -lnmd \   x x
x x-lnms0    /u01/app/oracle/product/8.0.5/rdbms/lib/defopt.o              x x
x x/u01/app/oracle/product/8.0.5/rdbms/lib/ssdbaed.o \                     x x
x x/u01/app/oracle/product/8.0.5/lib/nautab.o                              x x
x x/u01/app/oracle/product/8.0.5/lib/naeet.o                               x x
x x/u01/app/oracle/product/8.0.5/lib/naect.o                               x x
x x/u01/app/oracle/product/8.0.5/lib/naedhs.o `cat                         x x
x x/u01/app/oracle/product/8.0.5/lib/naldflgs` -lnetv2 -lnttcp -lnetwork - x x
x xlncr  -lnetv2 -lnttcp -lnetwork -lclient -lvsn -lcommon -lgeneric -lmm -x x
x xlnlsrtl3  -lcore4 -lnlsrtl3 -lcore4 -lnlsrtl3 -lnetv2 -lnttcp -lnetwork x x
x x-lncr  -lnetv2 -lnttcp -lnetwork -lclient -lvsn -lcommon -lgeneric  -   x x
x xlepc -lnlsrtl3  -lcore4 -lnlsrtl3 -lcore4 -lnlsrtl3 -lclient -lvsn -    x x
x xlcommon -lgeneric -lnlsrtl3  -lcore4 -lnlsrtl3 -lcore4 -lnlsrtl3   `cat x x
x x/u01/app/oracle/product/8.0.5/lib/sysliblist` -ldl -lm  -ltcl  -lm -ldl x x
x x-lc -lcrypt                                                             x x
x x/u01/app/oracle/product/8.0.5/lib//libcore4.a(lcd.o): In function       x x
x x`lcdprm':                                                               x x
x xlcd.o(.text+0xacb): the `gets' function is dangerous and should not be  x x
x xused.                                                                   x x
x x/u01/app/oracle/product/8.0.5/lib//libgeneric.a(skgfr.o): In function   x x
x x`skgfrcre':                                                             x x
x xskgfr.o(.text+0x4de): the `llseek' function may be dangerous;use        x x
x x`lseek64' instead.                                                      x x
x x/u01/app/oracle/product/8.0.5/network/lib/libnmi.a(snmitcln.o): In      x x
x xfunction `Nls_RegsubCmd':                                               x x
x xsnmitcln.o(.text+0x2780): undefined reference to `Tcl_RegsubCmd'        x x
x xcollect2: ld returned 1 exit status                                     x x
x xmake: *** [dbsnmp] Error 1                                              x x
Comment 8 Jakub Jelinek 2000-10-20 10:08:06 EDT
Again, this is Oracle's fault, they are using a non-exported libtcl symbol
(not declared in any of tcl public headers), so tcl was free to remove them.
Oracle has been notified about this, don't know whether they'll actually do
anything to fix it.
See #18319 for problems with Oracle 8.1.6 (again, Oracle's fault), which
fortunately they are going to address soon (though not in the best way, but
at least it should work for some time).
I'm marking this as NOTABUG, since its Oracle who needs to fix things, not us.
Comment 9 Steve Dixon 2000-10-20 12:14:53 EDT
Somehow I don't think they will fix 8.0.5 which is annoying, but thanks for the help.
Comment 10 Jakub Jelinek 2000-10-20 12:18:52 EDT
So if you have the possibility, install Oracle 8.0.5 on Red Hat 6.2 system
(so that the linking is done there) and if you copy the installation then
to 7.0 (together with libtcl 8.0 from 6.2), it could work...

Note You need to log in before you can comment on or make changes to this bug.