Bug 187443 - Clicking on the product doesn't update the versions.
Clicking on the product doesn't update the versions.
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 17:20 EST by Benjamin Kahn
Modified: 2007-04-18 13:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 23:40:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2006-03-30 17:20:08 EST
Description of problem:
Error: doOnSelectProduct is not defined
Source File: https://bugzilla.redhat.com/bugzilla/query.cgi
Line: 1

Clicking on the product doesn't update the versions.
Comment 1 David Lawrence 2006-03-30 23:40:38 EST
On that query page
(https://bugzilla.redhat.com/bugzilla/query.cgi?format=advanced) it will load by
default without loading the javascript necessary to update the versions and
components (faster page load). If you click on the link near the upper right
"Use Javascript" it will reload (setting a cookie) the page with all of the
necessary javascript to auto-update the versions and components when selecting a
product.
Comment 2 Benjamin Kahn 2006-03-31 08:17:23 EST
Okay....

Let's look at document sizes.  Without Javascript:  110 Kb

Document Size - https://bugzilla.redhat.com/bugzilla/query.cgi
	Documents (1 file)	281 kb
	https://bugzilla.redhat.com/bugzilla/query.cgi	4 kb
	Images (21 files)	6 kb
	https://www.redhat.com/g/chrome/logo_rh_home.png	1 kb
	https://www.redhat.com/g/chrome/link_worldwide.png	540 bytes
	https://rhn.redhat.com/img/contentnav_tabr.gif	411 bytes
	https://bugzilla.redhat.com/bugzilla/images/favicon.ico	318 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_bottom.png	313 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_top.png	311 bytes
	https://www.redhat.com/g/chrome/bkgrnd_greydots.png	234 bytes
	https://www.redhat.com/g/chrome/corner_secnav_bottom.png	226 bytes
	https://www.redhat.com/g/chrome/corner_secnav_top.png	226 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_tl.png	224 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_bl.png	221 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_tr_hi.png	209 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_br_hi.png	208 bytes
	https://www.redhat.com/g/chrome/link_utility_download.gif	186 bytes
	https://www.redhat.com/g/chrome/link_utility_support.gif	166 bytes
	https://www.redhat.com/g/chrome/link_utility_store.gif	151 bytes
	https://www.redhat.com/g/chrome/corner_secnav_bl.gif	101 bytes
	https://www.redhat.com/g/chrome/corner_secnav_tl.gif	101 bytes
	https://rhn.redhat.com/img/contentnav_tabl.gif	94 bytes
	https://www.redhat.com/g/chrome/corner_secnav_br.gif	74 bytes
	https://www.redhat.com/g/chrome/corner_secnav_tr.gif	74 bytes
	Style Sheets (9 files)	88 kb
	https://www.redhat.com/s/custom.css	25 kb
	https://www.redhat.com/s/pagelayout.css	16 kb
	https://www.redhat.com/s/headings.css	15 kb
	https://www.redhat.com/s/tables.css	11 kb
	https://www.redhat.com/s/navigation.css	10 kb
	https://bugzilla.redhat.com/bugzilla/css/bugzilla.css	6 kb
	https://www.redhat.com/s/global.css	5 kb
	https://bugzilla.redhat.com/bugzilla/css/query.css	1 kb
	https://www.redhat.com/s/master.css	861 bytes
	Scripts (1 file)	12 kb
	https://bugzilla.redhat.com/bugzilla/js/productform.js	12 kb
	Total	387 kb


With Javascript: 110Kb

Document Size -
https://bugzilla.redhat.com/bugzilla/query.cgi?rememberjs=1&format=advanced&help=
	Documents (1 file)	360Kb
	https://bugzilla.redhat.com/bugzilla/query.cgi?rememberjs=1&format=advanced&help=
4 kb
	Images (21 files)	6 kb
	https://www.redhat.com/g/chrome/logo_rh_home.png	1 kb
	https://www.redhat.com/g/chrome/link_worldwide.png	540 bytes
	https://rhn.redhat.com/img/contentnav_tabr.gif	411 bytes
	https://bugzilla.redhat.com/bugzilla/images/favicon.ico	318 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_bottom.png	313 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_top.png	311 bytes
	https://www.redhat.com/g/chrome/bkgrnd_greydots.png	234 bytes
	https://www.redhat.com/g/chrome/corner_secnav_bottom.png	226 bytes
	https://www.redhat.com/g/chrome/corner_secnav_top.png	226 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_tl.png	224 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_bl.png	221 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_tr_hi.png	209 bytes
	https://www.redhat.com/g/chrome/corner_mainnav_br_hi.png	208 bytes
	https://www.redhat.com/g/chrome/link_utility_download.gif	186 bytes
	https://www.redhat.com/g/chrome/link_utility_support.gif	166 bytes
	https://www.redhat.com/g/chrome/link_utility_store.gif	151 bytes
	https://www.redhat.com/g/chrome/corner_secnav_bl.gif	101 bytes
	https://www.redhat.com/g/chrome/corner_secnav_tl.gif	101 bytes
	https://rhn.redhat.com/img/contentnav_tabl.gif	94 bytes
	https://www.redhat.com/g/chrome/corner_secnav_br.gif	74 bytes
	https://www.redhat.com/g/chrome/corner_secnav_tr.gif	74 bytes
	Style Sheets (9 files)	88 kb
	https://www.redhat.com/s/custom.css	25 kb
	https://www.redhat.com/s/pagelayout.css	16 kb
	https://www.redhat.com/s/headings.css	15 kb
	https://www.redhat.com/s/tables.css	11 kb
	https://www.redhat.com/s/navigation.css	10 kb
	https://bugzilla.redhat.com/bugzilla/css/bugzilla.css	6 kb
	https://www.redhat.com/s/global.css	5 kb
	https://bugzilla.redhat.com/bugzilla/css/query.css	1 kb
	https://www.redhat.com/s/master.css	861 bytes
	Scripts (1 file)	12 kb
	https://bugzilla.redhat.com/bugzilla/js/productform.js	12 kb
	Total	466 kb

As near as I can tell, there is 20% difference.  But, more than that, the page
generates a Javascript error on page load, and on each product click.  It also
loses a LOT of functionality since we have 304 product versions in total, which
is a lot to scan through.

Note You need to log in before you can comment on or make changes to this bug.