Bug 187448 - nss_ldap aborts when trying to resolve secondary group name
nss_ldap aborts when trying to resolve secondary group name
Product: Fedora
Classification: Fedora
Component: nss_ldap (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 2006-03-30 17:50 EST by Yang Xiao
Modified: 2008-05-06 11:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 11:43:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Yang Xiao 2006-03-30 17:50:36 EST
Description of problem:
LDAP query aborts when trying to resolve user secondary group name when
configured to authenticate against AD Domain controllers

Version-Release number of selected component (if applicable):

How reproducible:
id username

Steps to Reproduce:
1.configure server as AD LDAP client
Actual results:
[root@host ~]# id yxiao
id: ../../../libraries/liblber/sockbuf.c:89: ber_sockbuf_ctrl: Assertion `(
(sb)->sb_opts.lbo_valid == 0x3 )' failed.
uid=188(yxiao) gid=100(users)Aborted

Expected results:
[root@host ~]# id yxiao
uid=188(yxiao) gid=100(users) groups=100(users)

Additional info:
If I comment out this line in the /etc/ldap.conf file
nss_map_objectclass posixGroup Group

the group names will not be resolved, but users can log in normally.
Comment 1 Chris Bradford 2006-06-18 08:53:41 EDT
I too have experienced exactly the same problems authenticating to a Windows
Server 2003 AD domain for authentication.

I found that re-installing nss_ldap fixes this probelm, TEMPORARILY however. SO
at the moment I have a script running every hour that re-install nss_ldap-250.

In order to install nss_ldap-250 I had to install the latest version of
OpenLDAP, and thus prior to that the latest version of BerkeleyDB.

Messy... to say the very least.

This problem is not present in FC4.
Comment 2 Chris Bradford 2006-06-26 06:04:57 EDT
I thought I'd add that without the above fix the majority of our users could not
log into the FC5 machines at all. GDM would reset, or the login prompt would
simply reset.
Comment 3 Chris Bradford 2006-07-04 08:36:06 EDT
This can actually be fixed in a far simpler way.

I noticed that FC4 does not have this issue and neither does Ubuntu 5.05 / 6.06.
The only differences were the nss_ldap library versions. In FC4 is it version
234 and in Ubuntu it is version 238.

Removing version 249-1 from FC5 and installing the FC4 nss_ldap-234-4 packagae
fixes this issue.

All users can login to workstations and there are no errors on obtaining groups.
Comment 4 Yang Xiao 2006-07-04 09:46:02 EDT
problem has one away after the latest FC5 kernel upgrade.
Comment 5 Chris Bradford 2006-07-05 10:35:06 EDT
Just tried it with a fresh install of FC5 and the latest kernel update.

This has not been fixed. The roll back of nss_ldap seems to be the only
permenant solution.
Comment 6 Yang Xiao 2006-07-05 10:53:20 EDT
it seems to have been fixed with the 2.6.16-1.2111_FC5 kernel

-bash-3.1$ id yxiao
uid=188(yxiao) gid=100(users) groups=100(users)
-bash-3.1$ uname -a
Linux spc15 2.6.16-1.2111_FC5 #1 Thu May 4 21:16:58 EDT 2006 i686 i686 i386
Comment 7 Chris Bradford 2006-07-05 10:59:10 EDT

I've tried the following kernel versions:


And all fail.
Comment 8 Yang Xiao 2006-07-05 11:31:27 EDT
ah, do you have the kernel-devel package installed? I had to install it for
something else, maybe that's what it was.
Comment 9 petrosyan 2008-03-13 19:33:40 EDT
Fedora Core 5 is no longer maintained. Is this bug still present in Fedora 7 or
Fedora 8?
Comment 10 Bug Zapper 2008-04-03 22:23:35 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 Bug Zapper 2008-05-06 11:43:06 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.