Bug 18745 - Get_local_host
Get_local_host
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 17:21 EDT by Tony Vickers
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 11:43:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Vickers 2000-10-09 17:21:21 EDT
upgraded from 6.2 to 7.0 via cdrom. Ever since my lpd is broken. Returns

error printing page to queue lp

error reason: Get_local_host: 'localhost' IP address not available!

This is from my messages log.
Oct  9 12:04:01 shellshock lpd: lpd shutdown failed
Oct  9 12:04:01 shellshock checkpc[952]: Get_local_host: 'localhost' IP 
address not available!
Oct  9 12:04:01 shellshock lpd[960]: Get_local_host: 'localhost' IP 
address not available!
Oct  9 12:04:01 shellshock lpd: 2000-10-09-12:04:01.802 shellshock 
Get_local_host: 'localhost' IP address not available!
Comment 1 Crutcher Dunnavant 2000-10-11 11:24:25 EDT
Please run:
rpm -q LPRng lpr

and submit the outcome. I need to know if you have LPRng on your system, or lpr.
Thanks.
Comment 2 Henry A. Danis 2000-11-03 01:05:54 EST
I am having the exact same problem with a new install of 7.0.  
I've run the rmp -q LPRng lpr with the following results
LPRng-3.6.22-5
package lpr is not installed
Comment 3 Crutcher Dunnavant 2001-02-09 17:36:00 EST
The fix for this is to edit /etc/hosts and add back the line that says:

127.0.0.1               localhost.localdomain localhost

Note You need to log in before you can comment on or make changes to this bug.