Bug 187462 - superfluous loading of eepro100 driver
superfluous loading of eepro100 driver
Status: CLOSED DUPLICATE of bug 187460
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 22:11 EST by Steve Snyder
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 14:46:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2006-03-30 22:11:34 EST
Description of problem:

Both the eepro100 and e100 drivers are being loaded to drive my Intel NIC

Version-Release number of selected component (if applicable):

kernel-smp-2.6.16-1.2069_FC4

How reproducible:

Always

Steps to Reproduce:
1. Install kernel-smp-2.6.16-1.2069_FC4 on system with Intel 82559-based 10/100 
Ethernet controller
2. Reboot to see that the eepro100 and e100 drivers have been loaded 
3.
  
Actual results:

2 drivers loaded; eepro100 is superfluous

Expected results:

Only the e100 driver should be loaded to drive my NIC

Additional info:

# grep 100 /etc/modprobe.conf
alias eth0 e1000
alias eth1 e100

(Don't be misled by the GBit NIC.  It is working fine.  This problem is new to 
the 2.6.16 kernel and is specific to my 100MBit controller.  In previous kernel 
versions only the e100 driver was loaded.)

# /sbin/lspci -v
00:00.0 Host bridge: Intel Corporation 82860 860 (Wombat) Chipset Host Bridge 
(MCH) (rev 04)
        Subsystem: Super Micro Computer Inc: Unknown device 2980
        Flags: bus master, fast devsel, latency 0
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corporation 82850 850 (Tehama) Chipset AGP Bridge (rev 
04) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        Memory behind bridge: f0000000-f2ffffff
        Prefetchable memory behind bridge: e0000000-efffffff

00:02.0 PCI bridge: Intel Corporation 82860 860 (Wombat) Chipset AGP Bridge (rev 
04) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, fast devsel, latency 32
        Bus: primary=00, secondary=02, subordinate=03, sec-latency=0
        I/O behind bridge: 00009000-00009fff
        Memory behind bridge: f3000000-f4ffffff
        Prefetchable memory behind bridge: 50000000-500fffff

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 04) (prog-if 00 
[Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=04, subordinate=04, sec-latency=32
        I/O behind bridge: 0000a000-0000afff
        Memory behind bridge: f5000000-f6ffffff
        Prefetchable memory behind bridge: 50100000-501fffff

00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 04)
        Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 04) (prog-if 80 
[Master])
        Subsystem: Super Micro Computer Inc: Unknown device 2980
        Flags: bus master, medium devsel, latency 0
        I/O ports at f000 [size=16]

00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 04) 
(prog-if 00 [UHCI])
        Subsystem: Super Micro Computer Inc: Unknown device 2980
        Flags: bus master, medium devsel, latency 0, IRQ 17
        I/O ports at b000 [size=32]

00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 04)
        Subsystem: Super Micro Computer Inc: Unknown device 2980
        Flags: medium devsel, IRQ 12
        I/O ports at 0500 [size=16]

00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 04) 
(prog-if 00 [UHCI])
        Subsystem: Super Micro Computer Inc: Unknown device 2980
        Flags: bus master, medium devsel, latency 0, IRQ 18
        I/O ports at b800 [size=32]

01:00.0 VGA compatible controller: nVidia Corporation NV40 [GeForce 6800 GT] 
(rev a1) (prog-if 00 [VGA])
        Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 21
        Memory at f0000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (32-bit, prefetchable) [size=256M]
        Memory at f1000000 (32-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at f2000000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 3.0

02:1f.0 PCI bridge: Intel Corporation 82806AA PCI64 Hub PCI Bridge (rev 03) 
(prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Bus: primary=02, secondary=03, subordinate=03, sec-latency=32
        I/O behind bridge: 00009000-00009fff
        Memory behind bridge: f3000000-f4ffffff
        Prefetchable memory behind bridge: 50000000-500fffff

03:00.0 PIC: Intel Corporation 82806AA PCI64 Hub Advanced Programmable Interrupt 
Controller (rev 01) (prog-if 20 [IO(X)-APIC])
        Subsystem: Intel Corporation 82806AA PCI64 Hub APIC
        Flags: fast devsel
        Memory at f4040000 (32-bit, non-prefetchable) [disabled] [size=4K]

03:02.0 Ethernet controller: Intel Corporation 82544EI Gigabit Ethernet 
Controller (Copper) (rev 02)
        Subsystem: Intel Corporation PRO/1000 XT Server Adapter
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 16
        Memory at f4020000 (32-bit, non-prefetchable) [size=128K]
        Memory at f4000000 (32-bit, non-prefetchable) [size=128K]
        I/O ports at 9000 [size=32]
        [virtual] Expansion ROM at 50000000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [e4] PCI-X non-bridge device.
        Capabilities: [f0] Message Signalled Interrupts: 64bit+ Queue=0/0 
Enable-

03:04.0 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
        Subsystem: Adaptec: Unknown device 2980
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 16
        BIST result: 00
        I/O ports at 9400 [disabled] [size=256]
        Memory at f4041000 (64-bit, non-prefetchable) [size=4K]
        [virtual] Expansion ROM at 50020000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2

03:04.1 SCSI storage controller: Adaptec AIC-7899P U160/m (rev 01)
        Subsystem: Adaptec: Unknown device 2980
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 16
        BIST result: 00
        I/O ports at 9800 [disabled] [size=256]
        Memory at f4042000 (64-bit, non-prefetchable) [size=4K]
        [virtual] Expansion ROM at 50040000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2

04:01.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear 
SoundFusion Audio Accelerator] (rev 01)
        Subsystem: Voyetra Technologies: Unknown device 3357
        Flags: bus master, slow devsel, latency 32, IRQ 20
        Memory at f6200000 (32-bit, non-prefetchable) [size=4K]
        Memory at f6100000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [40] Power Management version 2

04:04.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 
08)
        Subsystem: Intel Corporation EtherExpress PRO/100+ Server Adapter 
(PILA8470B)
        Flags: bus master, medium devsel, latency 32, IRQ 19
        Memory at f6201000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at a000 [size=64]
        Memory at f6000000 (32-bit, non-prefetchable) [size=1M]
        [virtual] Expansion ROM at 50100000 [disabled] [size=1M]
        Capabilities: [dc] Power Management version 2
Comment 1 Dave Jones 2006-04-04 14:46:10 EDT

*** This bug has been marked as a duplicate of 187460 ***

Note You need to log in before you can comment on or make changes to this bug.