Bug 187479 - tail no longer support +lines option
tail no longer support +lines option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 187713 215366 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 04:19 EST by Adam
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-31 04:23:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam 2006-03-31 04:19:35 EST
Description of problem:
The tail command no longer takes the +lines option to print lines starting
relative to the beginning of the file instead of the end.

Version-Release number of selected component (if applicable):
coreutils-5.93-7.2

How reproducible:
Every time

Steps to Reproduce:
1. echo -e "abc\ndef\nghi" | tail +2
  
Actual results:
tail: cannot open `+2' for reading: No such file or directory

Expected results:
def
ghi

Additional info:
This works as expected for FC4 coreutils-5.2.1-48.1
Comment 1 Tim Waugh 2006-03-31 04:23:33 EST
Please read the info page about Standards Conformance:

  info coreutils 'Standards Conformance'

In particular, you can re-enable this '+2' behaviour by setting an environment
variable:

  For example, if you have a newer system but are running
  software that assumes an older version of POSIX and uses `sort +1' or
  `tail +10', you can work around any compatibility problems by setting
  `_POSIX2_VERSION=199209' in your environment.
Comment 2 Ignacio Vazquez-Abrams 2006-04-03 00:03:15 EDT
*** Bug 187713 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2006-11-14 05:34:57 EST
*** Bug 215366 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.