Bug 18749 - rp3 fails/crashes when dial-out
rp3 fails/crashes when dial-out
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 18:17 EDT by Spider
Modified: 2007-04-18 12:29 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:35:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Spider 2000-10-09 18:17:53 EDT
Info: rp3-config -> Debug works perfectly but rp3 and using a connection
does not work.

Debug: 
Not avaiable. when run through gdb, nothing (abnormal) happens. still
doesnt connect though.
When run from normal shell, this is produced.

Gtk-WARNING **: invalid cast from `(unknown)' to `GtkProgressBar'

Gtk-CRITICAL **: file gtkprogressbar.c: line 751
(gtk_progress_bar_update): asse
rtion `GTK_IS_PROGRESS_BAR (pbar)' failed.

# Repeat ad infinitum

for the following session, rp3 claims to be OFFLINE.
when closed and restarted, rp3 claims -ONLINE-
##
once the stale pids are removed, and the pppd processess that were running
are killed, you can try again and it still wont work properly :(
if a user runs it it crashes, sometimes popping the bug report, sometimes
not.
when run through gdb, it doesn't crash, the progressmeter moves -slow- and
it doesn't connect.

$rpm -q rp3
rp3-1.1.4-4

$rpm -q -f /usr/include/gtk/gtkprogressbar.h 
gtk+-devel-1.2.8-7

$rpm -q gtk+
gtk+-1.2.8-7
Comment 1 Nalin Dahyabhai 2000-10-10 12:32:18 EDT
I thought we'd fixed the progress-bar problem before, but I'll take another
look.
Comment 2 mach 2000-10-20 02:33:11 EDT
I'm having the same problem, but instead of '(unknown)' on the first line of the
error message, I get the following:

Gtk-WARNING **: invalid cast from `GtkHBox' to `GtkProgressBar'

The second error line is identical...   Just thought replacing the '(unknown)'
might help someone.
Comment 3 wdezell 2000-10-31 14:32:58 EST
Same for me (debug of config tool works fine) except crash message from rp3 is
"Failed to activate interface".  ifconfig shows ppp0 (ppp1, etc...) but no dial
ever occurs.
Comment 4 Need Real Name 2000-11-08 09:37:58 EST
I had the same problem. I can get connected only by running manually
wvdial from root. rp3 is not working in my RH7 box
Comment 5 wdezell 2001-01-05 08:15:05 EST
So.... has anyone heard of progress towards resolving this issue?  An e-mail
inquiry to abrown & nalin a few weeks ago hasn't yielded a response yet.  Info
appreciated from anyone.
Comment 6 Jagadeesh Venugopal 2001-02-06 12:17:26 EST
Here is what worked for me:

Stop using RP3. Just use wvdial. Works like a charm.

Is RedHat serious about either (a) Fixing this bug or (b) Telling
users the workarounds? It has been about 4 months since the issue
was reported and precious little has happened. I would presume 
that the first thing people want to do with RHL is to connect to 
the Internet. Having such an obvious bug in the very first step
must be driving many people into the hands of your competitors...
Comment 7 Sean McMurtrey 2001-02-07 15:35:40 EST
Can wvdial be used by anyone other that root? Is RP3 a redhat thing or a GNOME 
thing? On a previous install I had it working fine for the root as well as the 
other users. Unfortunatley I didnt document what I did and in the process of 
trying to re-create the previous set I ran into the same GTK error (usually w/ 
the bug report prompt).
Comment 8 Need Real Name 2001-03-28 16:08:33 EST
Is this bug fixed yet?

Gtk-CRITICAL file gtkprogressbar.c line 751 (gtk_progress_bar_update): assertion
'GTK_IS_PROGRESS_BAR (pbar)' failed

rp3 does not dialout and hangs says that the device is connected when not even
connected, have to kiss the pid, only way to connect is via debug.

Only other work around i could think off was to install kppp but then thats not
fixing the bug is it.

Would apprieciate any feed back to the matter.

Regards

Nif
Comment 9 Bill Nottingham 2006-08-07 13:30:55 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 10 Bill Nottingham 2006-10-18 10:35:18 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.