Bug 187522 - Inconsistent behaviour with anaconda and no kernel package - "You are trying to install on a machine that isn't supported by this release.."
Inconsistent behaviour with anaconda and no kernel package - "You are trying ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 11:53 EST by Darragh Bailey
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEL5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 18:03:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-10.1.1.19_kernel_arch_check.patch - patch allows kernel-smp to be used as the only kernel package on i386 (1.22 KB, patch)
2006-03-31 11:53 EST, Darragh Bailey
no flags Details | Diff

  None (edit)
Description Darragh Bailey 2006-03-31 11:53:40 EST
Description of problem:

If you generate a custom install CD image with the kernel-smp package as the
only available kernel to be installed anaconda will fail to install on i686 with
the message:
"You are trying to install on a machine that isn't supported by this release of
RedHat Enterprise.."

This was previous reported as a bug for RHEL3 in bug106590 and was closed since
it was stated that it was a requirement that the kernel package be available.

We've noticed with our custom CD generation that this behaviour is limited to
i?86 architecture's only.

Removing the kernel package and regenerating the necessary files for x86_64 will
produce a CD that installs without this problem.


Version-Release number of selected component (if applicable):
10.1.1.19-1

How reproducible:
Always

Steps to Reproduce:
1. Remove all kernel images except the kernel-smp package from the source
install media
2. Change the comps file to just use kernel-smp
3. Regnerate the hdlist files and stage images (+ cd image in not using network
install)
4. Begin install
  
Actual results:
x86_64 - installs
i386 - install fails with message that it is not supported
ia64 - not tested but from analysis of the code expect this to be same as x86_64

Expected results:
Install should fail on all architectures or succeed on all architectures

Additional info:

Since we wanted to only have the kernel-smp package in the custom install image
we made the changes in the attached patch


A more ideal solution would be to make this consistent across all architectures.

I see two solutions 
1) Test for the present of the kernel package on all architectures, not just i386
2) Test for the present of any suitable kernel package on all architectures,
i.e. kernel, kernel-smp & kernel-hugemem

Obviously would prefer solution 2 since it would suit our requirements as well,
but at the very least would expect the behaviour to be consistent across all
architectures.
Comment 1 Darragh Bailey 2006-03-31 11:53:40 EST
Created attachment 127133 [details]
anaconda-10.1.1.19_kernel_arch_check.patch - patch allows kernel-smp to be used as the only kernel package on i386
Comment 2 Chris Lumens 2007-03-14 18:03:43 EDT
This shouldn't be a problem in RHEL5 as this code has completely changed.  If
you need a fix in an update release of RHEL4, please contact your support
representative who will raise this issue through the appropriate methods. 
Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.