Bug 187568 - No sound for non-root users
No sound for non-root users
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-31 18:54 EST by Anand Buddhdev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 05:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anand Buddhdev 2006-03-31 18:54:31 EST
Description of problem: No sound in KDE, because /dev/dsp is owned by root.


Version-Release number of selected component (if applicable): udev-084-13


How reproducible: Always


Steps to Reproduce:
1. Update a FC5 system with all the current updates (incl. udev-084-13)
2. Login as a normal (ie. non-root) user
3. Look at the permissions of /dev/dsp
  
Actual results:


Expected results:


Additional info:
Comment 1 Anand Buddhdev 2006-03-31 20:15:14 EST
I also just noticed that /dev/mixer is also owned by root, and so kmix in KDE
and alsamixer do not work either.
Comment 2 Anand Buddhdev 2006-04-03 05:51:01 EDT
Oops. Sorry to have opened this bug report. I have found the problem, and it was
my doing. I had modified my /etc/pam.d/kdm file to make use of pam_ssh. With the
changes in PAM in FC5, the ordering in the /etc/pam.d/kdm file meant that
pam_console was not getting executed. I've changed the order of the pam modules,
and now everything works fine. I'll change the status of the bug to NOTABUG.

Once again, apologies for opening this bug report.

Note You need to log in before you can comment on or make changes to this bug.