Bug 187600 - Screen and/or Irssi causing gnome-terminal freeze
Screen and/or Irssi causing gnome-terminal freeze
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 11:14 EST by Lauri Nurmi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.12.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 18:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lauri Nurmi 2006-04-01 11:14:52 EST
Description of problem:
I am using gnome-terminal to connect to two separate servers (in separate tabs),
both of which run screen + irssi. Occassionally, the whole terminal goes blue,
before I press Ctrl-L to make irssi redraw itself.

Besides that, the whole gnome-terminal sometimes freezes for 15..30 seconds,
during which it takes ~95% of CPU, and will not respond to anything (nor even
redraw itself).

In FC1, gnome-terminal had similar problems, except that it didn't recover from
frozen state, it had to be killed. In FC3, however, the problem was completely
gone, only very rarely did the terminal go blue, but never froze. Now FC5 has
reintrocude this problem?

Setting the severity to 'high', because this bug basically prevents me from
using gnome-terminal for what I used to do with it.

Version-Release number of selected component (if applicable):
gnome-terminal-2.14.0-1

How reproducible:
Seems that the bug doesn't (at least always) appear right away, but after the
terminal has been running for some time, a day or so. The problem may be linked
to having two irssis running through two screens, so far I haven't noticed
freezing when only one of them is open.

Steps to Reproduce:
1. ssh to a server, start screen + irssi
2. idle + type something
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lauri Nurmi 2006-05-10 18:46:16 EDT
Ok, I got tired of the freezing feature, and downloaded the SRPM for "vte" from
the FC3 updates (vte-0.11.14-3.fc3), then compiled and installed it.

Since then my gnome-terminal has not frozen, not even once. The "irssi blue
screen" effect does appear now and then, but that's tolerable.

To me it seems something was broken in the "vte" lib between FC3 and FC5.
Perhaps this bug report should be about vte rather than gnome-terminal.
Comment 2 Ville Ranki 2006-07-18 06:18:33 EDT
I believe this bug is fixed in current version. I've experienced it 
earlier on FC4 but currently it does not occur anymore.
Comment 3 Behdad Esfahbod 2006-07-27 18:05:51 EDT
Yes, the Blue Screen Of Death was fixed upstream and the freeze is fixed too I
guess.

Note You need to log in before you can comment on or make changes to this bug.