Bug 187645 - ipw2200-1.1.2 breaks wpa_supplicant with option ap_scan=1
ipw2200-1.1.2 breaks wpa_supplicant with option ap_scan=1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 03:13 EDT by Bill Moss
Modified: 2008-01-16 16:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 16:44:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
wpa_supplicant log (3.10 KB, text/plain)
2006-04-07 03:34 EDT, Bill Moss
no flags Details
NetworkManager debug log (35.33 KB, text/plain)
2006-04-07 03:37 EDT, Bill Moss
no flags Details

  None (edit)
Description Bill Moss 2006-04-02 03:13:44 EDT
The scan complete event code added to ipw2200-1.1.2 breaks wpa_supplicant when
the option ap_scan=1 is used. Association fails.


Version-Release number of selected component (if applicable):
wpa_supplicant-0.4.8-6.fc5.i386.rpm


How reproducible: Everytime


Steps to Reproduce:
1. Create a wpa_supplicant.conf file for a broadcasting AP using the option
ap_scan=1.
2. Use WEP.
3. Use the wext driver and -ddd option for debugging output.
  
Actual results: association with AP fails


Expected results: association with AP


Additional info:
Comment 1 Bill Moss 2006-04-07 03:34:19 EDT
Created attachment 127443 [details]
wpa_supplicant log

ipw2200-1.1.2 with Yi scan_fix.patch
wpa_supplicant-0.4.8-7.fc5
FC5 updated /4-6-06
NetworkManager-0.6.2

Since first report, ipw2200-1.1.2 has been patched so that it now works with
wpa_supplicant with the option ap_scan=1. When booting to wireless, NM
associates and then immediately drops the connection. If you force the
connection from the menu, a connection is made. wpa_supplicant log attached
with NetworkManager turned off and log attached for NetworkManager.
Comment 2 Bill Moss 2006-04-07 03:37:50 EDT
Created attachment 127444 [details]
NetworkManager debug log

pw2200-1.1.2 with Yi scan_fix.patch
wpa_supplicant-0.4.8-7.fc5
FC5 updated /4-6-06
NetworkManager-0.6.2

Since first report, ipw2200-1.1.2 has been patched so that it now works with
wpa_supplicant with the option ap_scan=1. When booting to wireless, NM
associates and then immediately drops the connection. If you force the
connection from the menu, a connection is made. wpa_supplicant log attached
with NetworkManager turned off and log attached for NetworkManager.
Comment 3 Dan Williams 2008-01-16 16:44:27 EST
I think this one should be OK now, so closing.  If it's still an issue, feel
free to reopen :)

Note You need to log in before you can comment on or make changes to this bug.