Bug 187652 - yumex crashes with a message to report the bug
yumex crashes with a message to report the bug
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 187651 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 06:48 EDT by jayadevan
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.99.16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-06 07:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jayadevan 2006-04-02 06:48:13 EDT
Description of problem:
Component: yumex
Version: 0.99.14
Summary: TBfe1799b6 yumexmain.py:561:delete_event:RuntimeError: called outside $
Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 561, in delete_event
    gtk.main_quit()
RuntimeError: called outside of a mainloop

Local variables in innermost frame:
widget: <gtk.Window object (GtkWindow) at 0xb797d234>
data: None
event: <GdkEvent at 0xb9d0f88>
self: <__main__.YumexMainApplication instance at 0xb797926c>



Version-Release number of selected component (if
applicable):yumex-0.99.14-1.0.fc5.noarch.rpm



How reproducible:

however, the product still works sometimes!

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-04-02 06:51:41 EDT
*** Bug 187651 has been marked as a duplicate of this bug. ***
Comment 2 Tim Lauridsen 2006-04-06 07:38:31 EDT
This happens when you try quiting yumex, when loading repo metadata.
Fixed i yumex 0.99.16 (being build at the moment).
Comment 3 Marcelo Ghelman 2006-05-27 23:33:53 EDT
Component: yumex
Version: 1.0.1
Summary: TBb43bbbbf yumexUtils.py:533:get_child_path_row:TypeError: could not
convert filter_path to a GtkTreePath

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 589, in
sort_size_column
    size2 = float( self.get_pkg(model,iter2).size )
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 522, in get_pkg
    row = self.get_child_path_row( path )
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 533, in
get_child_path_row
    storepath = self.filter.convert_path_to_child_path( filterpath )
TypeError: could not convert filter_path to a GtkTreePath

Local variables in innermost frame:
filterpath: None
self: <yumex.yumexUtils.pkgView instance at 0xb795de2c>
path: 1

Comment 4 Tim Lauridsen 2006-05-30 03:36:23 EDT
(In reply to comment #3)
> Component: yumex
> Version: 1.0.1
> Summary: TBb43bbbbf yumexUtils.py:533:get_child_path_row:TypeError: could not
> convert filter_path to a GtkTreePath
>

Why are you adding a new bugreport as a comment to another allready closed one.
Create a new bugzilla report.

Note You need to log in before you can comment on or make changes to this bug.