Bug 187662 - Networking problem: Incoming packets ignored in kernel 2.6.16-1.2069_FC4
Networking problem: Incoming packets ignored in kernel 2.6.16-1.2069_FC4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 08:18 EDT by Michael De La Rue
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-08 08:45:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
collection of system / rpm information (3.42 KB, text/plain)
2006-04-02 08:18 EDT, Michael De La Rue
no flags Details
log of system booting with kernel 2.6.16-1.2069_FC4 (24.85 KB, text/plain)
2006-04-02 08:23 EDT, Michael De La Rue
no flags Details
this file contains two (txt) logs from tcpdump (10.02 KB, text/plain)
2006-04-02 09:53 EDT, Michael De La Rue
no flags Details
kernel config file from failing 2.6.16 kernel (61.05 KB, application/octet-stream)
2006-04-08 03:32 EDT, Michael De La Rue
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 6353 None None None Never

  None (edit)
Description Michael De La Rue 2006-04-02 08:18:48 EDT
Description of problem:
Incoming network packets are not accepted when booting into kernel
2.6.16-1.2069_FC4.  There is no reaction to the packets and the system acts
broken.  Mouse movement in gnome desktop was also very jerky, but everything
else seems to work.  

Version-Release number of selected component (if applicable):
2.6.16-1.2069_FC4

How reproducible:
Every time

Steps to Reproduce:
1. Boot into kernel 2.6.16-1.2069_FC4
2. ping machine
3. no response
4. ping from machine
5. machine sends arp requests (at least sometimes) but fails to respond.
  
Actual results:
During boot I ping the machine continually; it never responds.  When I boot with
kernel 2.6.15-1.1833_FC4 it responds immediately eth0 is reported as coming up.  

When I have the machine up and ping from it, I can see arp requests on the
connected network.  The machine ignores repeated responses on the other side. 
When I switch back to kernel 1.1833_FC4 everything works correctly.

Expected results:
The machine should respond to pings.

Additional info:
I have two network cards  eth0 8139too and eth1 3c59x 

I did a number of tests to determine this.  Plugging in out / bringing up and
down interfaces / testing both of my ethernet cards / connecting three hosts to
the same network and verifying that the other two were working.  

It is possible that there were processes run from init continuously restarting
due to the lack of network.  The mouse movement problems may be unrelated to the
real problem.
Comment 1 Michael De La Rue 2006-04-02 08:18:48 EDT
Created attachment 127202 [details]
collection of system / rpm information
Comment 2 Michael De La Rue 2006-04-02 08:23:32 EDT
Created attachment 127203 [details]
log of system booting with kernel 2.6.16-1.2069_FC4

During this log I booted the system and pinged it continuously from another
machine over a cross cable.  No response was ever seen even though the same
setup worked immediately with the older kernel.  The machine has a static IP
address configured on eth0.
Comment 3 Michael De La Rue 2006-04-02 09:53:17 EDT
Created attachment 127204 [details]
this file contains two (txt) logs from tcpdump

Here are two logs from tcpdump.  The problem host is 192.168.0.2.  The default
router on that host is 192.168.0.1; at the start no such host is present on the
network.  The host 192.168.0.249 is where the tcpdump is running and is pinging
the host 192.168.0.2.  

For the second log I added the default router IP address to the test host part
way through (ip addr add 192.168.0.1 dev eth0).  From this point on it responds
to arp requests from the problem host, but the problem host doesn't seem to see
the response and keeps making requests.  

Even though I tried pinging 192.168.0.249 directly, I have never seen a related
arp request.
Comment 4 Michael De La Rue 2006-04-08 03:32:27 EDT
Created attachment 127498 [details]
kernel config file from failing 2.6.16 kernel

This bug is seems to be the same on a standard 2.6.16 kernel (based on the
package installed in the kernel src.rpm).  I guess then that it's not related
to Fedora specific issues.  I'm going to try to test it on the a recent kernel
and then try to report it upstream.
Comment 5 Michael De La Rue 2006-04-08 08:45:02 EDT
I have reproduced this in 2.6.16.2 also.  I've now put it into
bugzilla.kernel.org (see external bug reference).

Note You need to log in before you can comment on or make changes to this bug.