Bug 187676 - glibc-2.3.6-3 changes nsswitch.conf processing
glibc-2.3.6-3 changes nsswitch.conf processing
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 11:39 EDT by H.J. Lu
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 07:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2006-04-02 11:39:54 EDT
I had

hosts:      files nisplus nis dns

in /etc/nsswitch.conf. Before glibc-2.3.6-3, I had no problem looking up
external hostnames. After upgrading to glibc-2.3.6-3, I got

bash-3.00$ wget  http://www.kernel.org/pub/
--08:42:15--  http://www.kernel.org/pub/
           => `index.html'
Resolving www.kernel.org... failed: No such file or directory.

I had to use

hosts:      files dns

in /etc/nsswitch.conf. It looks like the new glibc treats

hosts:      files nisplus nis dns

as

hosts:      files nisplus nis [NOTFOUND=return] dns

BTW, I am not running YP.
Comment 1 Jakub Jelinek 2006-04-03 07:17:09 EDT

*** This bug has been marked as a duplicate of 186592 ***

Note You need to log in before you can comment on or make changes to this bug.