Bug 187680 - Software Manager Crashes
Summary: Software Manager Crashes
Status: CLOSED DUPLICATE of bug 186545
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-02 16:26 UTC by M. A. MacLain
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 18:37:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
software manager crash dump (653 bytes, application/octet-stream)
2006-04-09 15:12 UTC, gui ambros
no flags Details

Description M. A. MacLain 2006-04-02 16:26:41 UTC
Description of problem:
Component: Software Manager Crashes


Version-Release number of selected component (if applicable):
pirut-1.0.1-1

How reproducible: Cosistent


Steps to Reproduce:
1.Select Applications | Add/Remove Software
2.
3.
  
Actual results:
Program opens, starts to retrieve  software information, crashes, displays crash
window

Expected results:


Additional info:

Crash log:

Component: Software Manager
Summary: TB43b34ebc GroupSelector.py:407:populateCategories:TypeError: iter
should be a GtkTreeIter

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 363, in ?
    main()
  File "/usr/sbin/pirut", line 359, in main
    pm.run()
  File "/usr/sbin/pirut", line 288, in run
    self._showBrowse()
  File "/usr/sbin/pirut", line 225, in _showBrowse
    grpsel.doRefresh()
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 410, in
doRefresh
    self.populateCategories()
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 407, in
populateCategories
    sel.select_iter(i)
TypeError: iter should be a GtkTreeIter

Local variables in innermost frame:
i: None
cats: []
self: <pirut.GroupSelector.GroupSelector instance at 0xb79cbacc>
sel: <gtk.TreeSelection object (GtkTreeSelection) at 0xb797789c>

Comment 1 gui ambros 2006-04-09 15:12:44 UTC
Created attachment 127524 [details]
software manager crash dump

generated when trying to execute pirut manually. Steps to reproduce:
1. open terminal window
2. run pirut

Comment 2 Jeremy Katz 2006-04-10 18:37:38 UTC

*** This bug has been marked as a duplicate of 186545 ***


Note You need to log in before you can comment on or make changes to this bug.