Bug 187717 - russian locale ru_RU.cp1251 missed
russian locale ru_RU.cp1251 missed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 00:58 EDT by DmitryBezgodov
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 05:50:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DmitryBezgodov 2006-04-03 00:58:21 EDT
Description of problem:


Version-Release number of selected component (if applicable):
glibc-2.4-4

How reproducible:
looking for russian locales:
locale -a |grep ru
ru_RU
ru_RU.iso88595
ru_RU.koi8r
ru_RU.utf8
russian
ru_UA
ru_UA.koi8u
ru_UA.utf8
------- cp1251 missed!

then, we'll create it 
localedef -c -i ru_RU -f cp1251 ru_RU.CP1251
locale -a |grep -i ru_RU.cp1251
ru_RU.cp1251
---- then it presents

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

cp1251 is standard of Microsoft' design of russian codepage. 
I'm using cp1251 for oracle app server, java and apache httpd.
The locale is important, because it is used often as result of moving  or
porting software that's worked on MS Windows. 
On my project it's required to recreate cp1251 locale everytime after update
glibc. the problem takes place on rh9, fc1-fc5. 

Regards, Dmitry Bezgodov
Comment 1 Jakub Jelinek 2006-04-03 05:50:32 EDT
We ship localedef so that users can easily build their locales.
Shipping a locale in 3 different charsets is more than sufficient, especially
when everybody should be using UTF-8 these days anyway.

Note You need to log in before you can comment on or make changes to this bug.