Bug 18772 - XFree86 Voodoo3 acceleration doesn't work -- missing file?
XFree86 Voodoo3 acceleration doesn't work -- missing file?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 01:31 EDT by John William
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 12:42:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John William 2000-10-10 01:31:01 EDT
I have done a standard Workstation install with RH 7.

The machine includes a Diamond Monster Fusion PCI (Banshee) card, which 
XFree recognizes. "lsmod" indicates that the tdfx.o kernel module is 
installed. The screen resolution is set to 16 bit depth. I am using the 
root account to try and run accelerated programs to overcome the "0666" 
permission problem on the accelerated device.

There is still no 3d acceleration available. This appears to be because 
the tdfx_dri.so acceleration library was not installed 
in /usr/X11R6/lib/modules/dri/ by the XFree86 RPM. I have verified ("rpm -
V") all the XFree packages, and everything is installed "ok", but no sign 
of the tdfx_dri.so module.
Comment 1 Scott Dowdle 2000-10-25 00:32:56 EDT
Did you load the Glide packages on the 2nd CD in the preview (I think that's 
what it is called) directory?
Comment 2 Mike A. Harris 2001-01-26 04:39:19 EST
The tdfx dri was broken in 4.0.1 and was disabled because of it.
As such tdfx DRI is unsupported in Red Hat 7.0.

The latest build in rawhide includes the tdfx dri however if you want to
test it out.

Note You need to log in before you can comment on or make changes to this bug.