Bug 187726 - webalizer's country code list is too old + .com is not "US Commercial"
webalizer's country code list is too old + .com is not "US Commercial"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: webalizer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 05:28 EDT by Jarkko
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version: 2.01_10-30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-16 10:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated tld list from http://en.wikipedia.org/wiki/List_of_Internet_top-level_domains (36.23 KB, patch)
2006-04-03 05:28 EDT, Jarkko
no flags Details | Diff

  None (edit)
Description Jarkko 2006-04-03 05:28:54 EDT
Description of problem: The country code list is too old for us. We get too much
unresolved because of this. The list should be updated to the latest tld list.

Version-Release number of selected component (if applicable): All versions up to
webalizer-2.01_10-29.2.1

How reproducible: Always of course. ;)

Steps to Reproduce:
1. Install webalizer.
2. Run it.
3. Look at the country statistics. (Well, you need to have a site which gets
visits from the missing countries naturally.)
  
Actual results: Too many unresolved countries.

Expected results: The country code list should contain the current tlds. The
list is many many years old.

Additional info: Patch attached. Well, it changes the english version only. But,
in real life that's the only language used because the language selection is
done in compile time. The tld list was taken from en.wikipedia.org because I
found a complete list from there. It should be reliable.
Comment 1 Jarkko 2006-04-03 05:28:54 EDT
Created attachment 127227 [details]
Updated tld list from http://en.wikipedia.org/wiki/List_of_Internet_top-level_domains
Comment 2 Joe Orton 2006-06-16 10:03:48 EDT
Thanks a lot for the patches, Jarkko (and sorry for the delay!) - I've committed
all of these; should hit Raw Hide once the test1 freeze is over.

Note You need to log in before you can comment on or make changes to this bug.