Bug 187730 - snd_powermac freezes powermac g5 dual
Summary: snd_powermac freezes powermac g5 dual
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: ppc64 Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-03 10:05 UTC by shrek-m
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 18:49:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description shrek-m 2006-04-03 10:05:00 UTC
Description of problem:
beginning with
  2.6.16-1.2106_FC6.ppc64
  2.6.16-1.2112_FC6.ppc64
  2.6.16-1.2114_FC6.ppc64
my powermac g5 dual hangs while booting,

'noapic' 'acpi=off' 'nosoftlockup'  = does not help
older kernel are ok.

booting in runlevel 1 is ok
booting in interactive mode without "local" was the solution.

the problem was my own  rc.local  because the sound does not work without this line.
----
modprobe snd_powermac
----


the  /var/log/messages  after modprobing in runlevel 3, the machine freezes

---- modprobe snd_powermac ----
Apr  3 11:48:32 pmg5 kernel: Unable to handle kernel paging request for data at
address 0x00000000
Apr  3 11:48:32 pmg5 kernel: Faulting instruction address: 0xc0000000000383b4
Apr  3 11:48:32 pmg5 kernel: Unable to handle kernel paging request for data at
address 0x00000000
Apr  3 11:48:32 pmg5 kernel: Faulting instruction address: 0xc0000000000383b4
Apr  3 11:48:32 pmg5 kernel: Unable to handle kernel paging request for data at
address 0x00000000
Apr  3 11:48:32 pmg5 kernel: Faulting instruction address: 0xc0000000000383b4
Apr  3 11:48:32 pmg5 kernel: Unable to handle kernel paging request for data at
address 0x00000000
Apr  3 11:48:32 pmg5 kernel: Faulting instruction address: 0xc0000000000383b4
Apr  3 11:48:32 pmg5 kernel: Unable to handle kernel paging request for data at
address 0x00000000
Apr  3 11:48:32 pmg5 kernel: Faulting instruction address: 0xc0000000000383b4
Apr  3 11:48:34 pmg5 kernel: Unable to handle kernel paging request for data at
address 0x00000000
Apr  3 11:48:34 pmg5 kernel: Faulting instruction address: 0xc0000000000383b4
--------


Additional info:
here are my old /var/log/messages
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187377#c1

Comment 1 shrek-m 2006-04-09 22:21:34 UTC
2.6.16-1.2118_FC6.ppc64 = freeze
2.6.16-1.2121_FC6.ppc64 = freeze
2.6.16-1.2122_FC6.ppc64 = freeze

still no sound and the machine freezes while `modprobe snd-powermac`
ciao.

Comment 2 shrek-m 2006-04-18 18:49:28 UTC
kernel-2.6.16-1.2134_FC6.ppc64
or the latest udev, initscripts, ... updates.

the powermac is turning off the machine again while booting, see bug #187377
or the machine is completely freezing short after booting.

seldom bootable after updates, not really bluetooth mouse/keyboard, not really
sound, X not really useable more russian roulette, ...
== after playing several months with rawhide on this powermac the steps are
going more backward than forward.
i can not see that fc6 or rhel5 could be a real target for me.

thanks, "mac os x" and "mac os x server" was my solution for the powermac.

closed.


Note You need to log in before you can comment on or make changes to this bug.