Bug 187734 - fluxbox startup file contains wrong invokation of fluxbox-generate_menu
fluxbox startup file contains wrong invokation of fluxbox-generate_menu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fluxbox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 07:52 EDT by Till Maas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 08:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2006-04-03 07:52:37 EDT
Description of problem: 
 
/usr/bin/startfluxbox contains 
 
     79 if [ -x /usr/bin/fluxbox-xdg-menu.py ]; then 
     80  /usr/bin/fluxbox-generate_menu --with-icons & 
     81 fi 
 
to create the menu of fluxbox. This does not work because 
fluxbox-generate_menu does not accept gnu-longoptions. 
 
I guess it was intendet to change this to  
 
     79 if [ -x /usr/bin/fluxbox-xdg-menu.py ]; then 
     80  /usr/bin/fluxbox-xdg-menu.py --with-icons & 
     81 fi 
 
because fluxbox-xdg-menu accepts the option --with-icons. 
 
Version-Release number of selected component (if applicable): 
 
0.9.15-1.fc5
Comment 1 Andreas Bierfert 2006-04-03 08:14:52 EDT
Ups, thanks for reporting :)
Comment 2 Till Maas 2006-04-03 08:29:59 EDT
I just saw that the .py extensions needs to be removed, so this is correct: 
 
     79 if [ -x /usr/bin/fluxbox-xdg-menu ]; then  
     80  /usr/bin/fluxbox-xdg-menu --with-icons &  
     81 fi  

Note You need to log in before you can comment on or make changes to this bug.