Bug 187774 - mount.cifs fails on x86_64
mount.cifs fails on x86_64
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Vince Worthington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 11:27 EDT by Wes Armour
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 14:48:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport as requested (573.45 KB, application/x-bzip2)
2006-05-09 04:44 EDT, Wes Armour
no flags Details

  None (edit)
Description Wes Armour 2006-04-03 11:27:36 EDT
Description of problem:

1) I do a chmod u+s on mount mount.cifs and umount.cifs

2) I add a line to my fstab:

//windows-2003-server/my-home-dir$ /mnt/U cifs
username=domain/my-login,uid=username,gid=username,users,noauto 0 0

3) I do a 

mount /mnt/U 

as a user and I get:

[me@my-pc ~]$ mount /mnt/U
Password: 
*** glibc detected *** /sbin/mount.cifs: free(): invalid pointer:
0x0000000000509592 ***
======= Backtrace: =========
/lib64/libc.so.6[0x3292f6d7a3]
/lib64/libc.so.6(__libc_free+0x84)[0x3292f6d924]
/sbin/mount.cifs[0x4038ad]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x3292f1d084]
/sbin/mount.cifs[0x401459]
======= Memory map: ========
00400000-00405000 r-xp 00000000 fd:00 3801312                           
/sbin/mount.cifs
00505000-00506000 rw-p 00005000 fd:00 3801312                           
/sbin/mount.cifs
00506000-005cc000 rw-p 00506000 00:00 0                                  [heap]
3292b00000-3292b19000 r-xp 00000000 fd:00 1048805                       
/lib64/ld-2.4.so
3292c19000-3292c1a000 r--p 00019000 fd:00 1048805                       
/lib64/ld-2.4.so
3292c1a000-3292c1b000 rw-p 0001a000 fd:00 1048805                       
/lib64/ld-2.4.so
3292f00000-329303f000 r-xp 00000000 fd:00 1048806                       
/lib64/libc-2.4.so
329303f000-329313f000 ---p 0013f000 fd:00 1048806                       
/lib64/libc-2.4.so
329313f000-3293143000 r--p 0013f000 fd:00 1048806                       
/lib64/libc-2.4.so
3293143000-3293144000 rw-p 00143000 fd:00 1048806                       
/lib64/libc-2.4.so
3293144000-3293149000 rw-p 3293144000 00:00 0 
3293400000-3293402000 r-xp 00000000 fd:00 1048808                       
/lib64/libdl-2.4.so
3293402000-3293502000 ---p 00002000 fd:00 1048808                       
/lib64/libdl-2.4.so
3293502000-3293503000 r--p 00002000 fd:00 1048808                       
/lib64/libdl-2.4.so
3293503000-3293504000 rw-p 00003000 fd:00 1048808                       
/lib64/libdl-2.4.so
3295800000-329580d000 r-xp 00000000 fd:00 1048811                       
/lib64/libgcc_s-4.1.0-20060304.so.1
329580d000-329590d000 ---p 0000d000 fd:00 1048811                       
/lib64/libgcc_s-4.1.0-20060304.so.1
329590d000-329590e000 rw-p 0000d000 fd:00 1048811                       
/lib64/libgcc_s-4.1.0-20060304.so.1
3298000000-3298011000 r-xp 00000000 fd:00 1048635                       
/lib64/libresolv-2.4.so
3298011000-3298111000 ---p 00011000 fd:00 1048635                       
/lib64/libresolv-2.4.so
3298111000-3298112000 r--p 00011000 fd:00 1048635                       
/lib64/libresolv-2.4.so
3298112000-3298113000 rw-p 00012000 fd:00 1048635                       
/lib64/libresolv-2.4.so
3298113000-3298115000 rw-p 3298113000 00:00 0 
3298600000-3298602000 r-xp 00000000 fd:00 1048814                       
/lib64/libcom_err.so.2.1
3298602000-3298701000 ---p 00002000 fd:00 1048814                       
/lib64/libcom_err.so.2.1
3298701000-3298702000 rw-p 00001000 fd:00 1048814                       
/lib64/libcom_err.so.2.1
2ad18df9f000-2ad18dfa0000 rw-p 2ad18df9f000 00:00 0 
2ad18dfc5000-2ad18dfc7000 rw-p 2ad18dfc5000 00:00 0 
2ad18dfc7000-2ad18dfd1000 r-xp 00000000 fd:00 1048604                   
/lib64/libnss_files-2.4.so
2ad18dfd1000-2ad18e0d0000 ---p 0000a000 fd:00 1048604                   
/lib64/libnss_files-2.4.so
2ad18e0d0000-2ad18e0d1000 r--p 00009000 fd:00 1048604                   
/lib64/libnss_files-2.4.so
2ad18e0d1000-2ad18e0d2000 rw-p 0000a000 fd:00 1048604                   
/lib64/libnss_files-2.4.so
2ad18e0d2000-2ad18e0d6000 r-xp 00000000 fd:00 1048602                   
/lib64/libnss_dns-2.4.so
2ad18e0d6000-2ad18e1d6000 ---p 00004000 fd:00 1048602                   
/lib64/libnss_dns-2.4.so
2ad18e1d6000-2ad18e1d7000 r--p 00004000 fd:00 1048602                   
/lib64/libnss_dns-2.4.so
2ad18e1d7000-2ad18e1d8000 rw-p 00005000 fd:00 1048602                   
/lib64/libnss_dns-2.4.so
2ad18e1d8000-2ad18e468000 r-xp 00000000 fd:00 1048791                   
/lib64/libnss_ldap-2.3.90.so
2ad18e468000-2ad18e568000 ---p 00290000 fd:00 1048791                   
/lib64/libnss_ldap-2.3.90.so
2ad18e568000-2ad18e590000 rw-p 00290000 fd:00 1048791                   
/lib64/libnss_ldap-2.3.90.so
2ad18e590000-2ad18e5a0000 rw-p 2ad18e590000 00:00 0 
2ad18e600000-2ad18e621000 rw-p 2ad18e600000 00:00 0 

Although it seems to baulk does mount.

It works fine on my i386 box.

Version-Release number of selected component (if applicable):

?

How reproducible:

Always.

Steps to Reproduce:
1. As above.
2.
3.
  
Actual results:

Baulk

Expected results:

Clean mount no complaining.

Additional info:

None.
Comment 1 Wes Armour 2006-05-04 05:58:13 EDT
I have installed the x86 version and I still get the same problem:

*** glibc detected *** /sbin/mount.cifs: free(): invalid pointer: 0x09ac0a42 ***
======= Backtrace: =========
/lib/libc.so.6[0x95ff18]
/lib/libc.so.6(__libc_free+0x79)[0x96341d]
/sbin/mount.cifs[0x804b48d]
/lib/libc.so.6(__libc_start_main+0xdc)[0x9117e4]
/sbin/mount.cifs[0x8048ee1]
======= Memory map: ========
00111000-003b8000 r-xp 00000000 09:01 3296879    /lib/libnss_ldap-2.3.90.so
003b8000-003cf000 rw-p 002a7000 09:01 3296879    /lib/libnss_ldap-2.3.90.so
003cf000-003de000 rw-p 003cf000 00:00 0 
006a5000-006b4000 r-xp 00000000 09:01 3296709    /lib/libresolv-2.4.so
006b4000-006b5000 r--p 0000e000 09:01 3296709    /lib/libresolv-2.4.so
006b5000-006b6000 rw-p 0000f000 09:01 3296709    /lib/libresolv-2.4.so
006b6000-006b8000 rw-p 006b6000 00:00 0 
007f1000-007f3000 r-xp 00000000 09:01 3298530    /lib/libcom_err.so.2.1
007f3000-007f4000 rw-p 00001000 09:01 3298530    /lib/libcom_err.so.2.1
008da000-008db000 r-xp 008da000 00:00 0          [vdso]
008db000-008f4000 r-xp 00000000 09:01 3298500    /lib/ld-2.4.so
008f4000-008f5000 r--p 00018000 09:01 3298500    /lib/ld-2.4.so
008f5000-008f6000 rw-p 00019000 09:01 3298500    /lib/ld-2.4.so
008fc000-00a28000 r-xp 00000000 09:01 3298522    /lib/libc-2.4.so
00a28000-00a2b000 r--p 0012b000 09:01 3298522    /lib/libc-2.4.so
00a2b000-00a2c000 rw-p 0012e000 09:01 3298522    /lib/libc-2.4.so
00a2c000-00a2f000 rw-p 00a2c000 00:00 0 
00a58000-00a5a000 r-xp 00000000 09:01 3298524    /lib/libdl-2.4.so
00a5a000-00a5b000 r--p 00001000 09:01 3298524    /lib/libdl-2.4.so
00a5b000-00a5c000 rw-p 00002000 09:01 3298524    /lib/libdl-2.4.so
00bce000-00bd2000 r-xp 00000000 09:01 3296679    /lib/libnss_dns-2.4.so
00bd2000-00bd3000 r--p 00003000 09:01 3296679    /lib/libnss_dns-2.4.so
00bd3000-00bd4000 rw-p 00004000 09:01 3296679    /lib/libnss_dns-2.4.so
00cf5000-00cfe000 r-xp 00000000 09:01 3296681    /lib/libnss_files-2.4.so
00cfe000-00cff000 r--p 00008000 09:01 3296681    /lib/libnss_files-2.4.so
00cff000-00d00000 rw-p 00009000 09:01 3296681    /lib/libnss_files-2.4.so
00df2000-00dfd000 r-xp 00000000 09:01 3298527    /lib/libgcc_s-4.1.0-20060304.so.1
00dfd000-00dfe000 rw-p 0000a000 09:01 3298527    /lib/libgcc_s-4.1.0-20060304.so.1
08048000-0804d000 r-xp 00000000 09:01 2023791    /sbin/mount.cifs
0804d000-0804e000 rw-p 00004000 09:01 2023791    /sbin/mount.cifs
09abe000-09b65000 rw-p 09abe000 00:00 0          [heap]
b7e00000-b7e21000 rw-p b7e00000 00:00 0 
b7e21000-b7f00000 ---p b7e21000 00:00 0 
b7f7a000-b7f7b000 rw-p b7f7a000 00:00 0 
b7f90000-b7f91000 rw-p b7f90000 00:00 0 
bfd7a000-bfd90000 rw-p bfd7a000 00:00 0          [stack]

I think it must be a processor issue because I don't have this problem on my laptop.

 cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) D CPU 3.00GHz
stepping        : 7
cpu MHz         : 2992.687
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
                                                                               
                                                                               
                      pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe
nx lm constant_tsc pni                                                         
                                                                               
                                             monitor ds_cpl est cid cx16 xtpr
lahf_lm
bogomips        : 5991.84

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) D CPU 3.00GHz
stepping        : 7
cpu MHz         : 2992.687
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
                                                                               
                                                                               
                      pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe
nx lm constant_tsc pni                                                         
                                                                               
                                             monitor ds_cpl est cid cx16 xtpr
lahf_lm
bogomips        : 5985.46

Although it mounts mount doesn't register it.

Thanks,

Wes.
Comment 2 Vince Worthington 2006-05-04 10:55:15 EDT
Hello,

So far I have been unable to reproduce this behavior testing on an x86_64
machine with FC5 installed and all updated packages available from the
fedora.-updates repo installed.  I have tested against shares on Windows 2000
and Windows 2003 domain controllers, using the same mount options syntax you
have used, and with normal and "hidden" share names.  I also tried specifying
the server by IP and unqualified hostname (which would resolve using the domains
appended by the search argument in /etc/resolv.conf), as well as deliberately
specifying an incorrect unqualified hostname guaranteed not to be resolvable,
but in all cases was unable to trigger the problem.  It may be an issue that has
already been corrected.

Can you confirm which version of the samba-client package is installed?  Have
you installed any updates on these systems?

Comment 3 Wes Armour 2006-05-04 11:02:15 EDT
Hi,

I'm using:

rpm -qa samba-client
samba-client-3.0.22-1.fc5

I find that I dont get this problem on my laptop which has exactly the same
install of core 5 on it. So I'm guessing it is something to do with my desktop
computer hardware, it is a dell precision 380.

Thanks,

Wes.
Comment 4 Vince Worthington 2006-05-08 11:16:37 EDT
Hello,

It could be a CPU/hardware issue -- this is definitely possible, but we should
probably look a little harder at the package versions of core packages and
libraries on the system.

I could ask for various specifics but it would probably be simpler to have you
run the sysreport utility your system should have on it.  This will collect
various hardware data as well as a lot of information about the packages on your
system.  Would you mind running 'sysreport' as the root user and attach its
output file to this bugzilla when it completes?  It's normal for this to take
several minutes for this to run as it also checks the installed RPM's for
corrupted files.

Comment 5 Wes Armour 2006-05-09 04:44:40 EDT
Created attachment 128772 [details]
sysreport as requested

Hi 

Attached is the sysreport that you requested.

Thanks,

Wes.
Comment 7 Simo Sorce 2007-11-23 14:48:55 EST
Fc5 is out of maintenance now, but this issue should be fixed in recent
releases, please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.