Bug 187778 - logwatch.fc5 older than logwatch.fc4
logwatch.fc5 older than logwatch.fc4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 11:59 EDT by Mostafa Afgani
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 03:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mostafa Afgani 2006-04-03 11:59:35 EDT
Description of problem:
Last friday I upgraded a fully updates FC4 box to FC5. The upgrade was
flawless. While looking for leftover FC4 packages, I came across:

[afgani@cpc155 ~]$ rpm -qa --qf %-30{NAME}' '%{DISTRIBUTION}'\n' | grep
"(FC-4)"$
logwatch                       Red Hat (FC-4)
tzdata                         Red Hat (FC-4)

and a few others (kernel_FC4, hal.fc4, gnome-kerberos,
system-config-mouse) which were easily removed.

Comparing version numbers:

[afgani@cpc155 ~]$ sudo yum list tzdata logwatch
Loading "installonlyn" plugin
Setting up repositories
core                                                                 [1/3]
core                      100% |=========================| 1.1 kB    00:00
updates                                                              [2/3]
updates                   100% |=========================|  951 B    00:00
extras                                                               [3/3]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Installed Packages
logwatch.noarch                          7.2.1-1.fc4            installed
tzdata.noarch                            2006b-2.fc4            installed
Available Packages
logwatch.noarch                          7.1-8                  core
tzdata.noarch                            2006b-1                core

it seems that fc4 contains updated packages while fc5 does not. These
updates were released on March 22nd but the fc5 packages are dated March
6th. I searched the updates and testing branches of fc5 but it looks like
updates to those packages are not even in testing yet. I then looked
through the development branch and saw a 7.3 version of logwatch; but the
version of tzdata was still 2006b-1 (i.e. even older than the fc4 update)

Version-Release number of selected component (if applicable):
7.2.1-1.fc4

How reproducible:
always

Steps to Reproduce:
1. Start with fully updated FC4
2. yum update to FC5
3. FC4 logwatch remains since it is newer
  
Actual results:
logwatch left behind from FC4 due to higher version #

Expected results:
fc5 version has higher version #

Additional info:
'tzdata' has the same problem (fc5 version lower than fc4 update)
Comment 1 Ivana Varekova 2006-04-05 03:34:36 EDT
Thank you for your bug report. This problem is fixed by new fc5 version
logwatch-7.2.1-1.fc5. 

Note You need to log in before you can comment on or make changes to this bug.