Bug 187793 - Excessive dependencies for mail-notification
Excessive dependencies for mail-notification
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 13:00 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 12:44:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which makes mail-notification hide the 'evolution' mailbox-type when the evolution plugin is not installed (2.25 KB, patch)
2006-09-23 07:08 EDT, Erik van Pienbroek
no flags Details | Diff
Necessary changes to the spec file to apply the evolution plugin-detection patch (747 bytes, patch)
2006-09-23 07:09 EDT, Erik van Pienbroek
no flags Details | Diff

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2006-04-03 13:00:00 EDT
Description of problem:
% sudo yum install mail-notification
Password:
Setting up Install Process
Setting up repositories
updates                                                              [2/4]
updates                   100% |=========================|  951 B    00:00
core                                                                 [3/4]
core                      100% |=========================| 1.1 kB    00:00
extras                                                               [4/4]
extras                                                          1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  68 kB    00:00
updates   : ################################################## 217/217
Added 67 new packages, deleted 0 old in 0.93 seconds
primary.xml.gz            100% |=========================| 871 kB    00:03
extras    : ################################################## 2448/2448
Added 173 new packages, deleted 25 old in 6.26 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mail-notification to pack into transaction set.
mail-notification-2.0-11. 100% |=========================| 337 kB    00:01
---> Package mail-notification.i386 0:2.0-11.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libeutil.so.0 for package: mail-notification
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for evolution to pack into transaction set.
evolution-2.6.0-1.i386.rp 100% |=========================| 126 kB    00:00
---> Package evolution.i386 0:2.6.0-1 set to be updated
--> Running transaction check
--> Processing Dependency: libgpilotdconduit.so.2 for package: evolution
--> Processing Dependency: libgpilotd.so.2 for package: evolution
--> Processing Dependency: libpisock.so.9 for package: evolution
--> Processing Dependency: gnome-pilot >= 2.0.13 for package: evolution
--> Processing Dependency: libpisync.so.0 for package: evolution
--> Processing Dependency: libnm_glib.so.0 for package: evolution
--> Processing Dependency: libgpilotdcm.so.2 for package: evolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for NetworkManager-glib to pack into transaction set.
NetworkManager-glib-0.6.0 100% |=========================|  16 kB    00:00
---> Package NetworkManager-glib.i386 0:0.6.0-3 set to be updated
---> Downloading header for gnome-pilot to pack into transaction set.
gnome-pilot-2.0.13-7.fc5. 100% |=========================|  27 kB    00:00
---> Package gnome-pilot.i386 0:2.0.13-7.fc5.4 set to be updated
---> Downloading header for pilot-link to pack into transaction set.
pilot-link-0.12.0-0.pre4. 100% |=========================|  22 kB    00:00
---> Package pilot-link.i386 1:0.12.0-0.pre4.5.2.1 set to be updated
--> Running transaction check
--> Processing Dependency: NetworkManager = 0.6.0-3 for package: NetworkManager-glib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for NetworkManager to pack into transaction set.
NetworkManager-0.6.0-3.i3 100% |=========================|  26 kB    00:00
---> Package NetworkManager.i386 0:0.6.0-3 set to be updated
--> Running transaction check
--> Processing Dependency: dhcdbd for package: NetworkManager
--> Processing Dependency: bind >= 24:9.3.1-20 for package: NetworkManager
--> Processing Dependency: libnl.so.1 for package: NetworkManager
--> Processing Dependency: wpa_supplicant for package: NetworkManager
--> Processing Dependency: caching-nameserver for package: NetworkManager
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for bind to pack into transaction set.
bind-9.3.2-12.FC5.i386.rp 100% |=========================|  41 kB    00:00
---> Package bind.i386 30:9.3.2-12.FC5 set to be updated
---> Downloading header for bind-config to pack into transaction set.
bind-config-9.3.2-12.FC5. 100% |=========================|  34 kB    00:00
---> Package bind-config.i386 30:9.3.2-12.FC5 set to be updated
---> Downloading header for dhcdbd to pack into transaction set.
dhcdbd-1.12-1.FC5.2.i386. 100% |=========================| 6.4 kB    00:00
---> Package dhcdbd.i386 0:1.12-1.FC5.2 set to be updated
---> Downloading header for libnl to pack into transaction set.
libnl-1.0-0.8.pre5.i386.r 100% |=========================| 3.4 kB    00:00
---> Package libnl.i386 0:1.0-0.8.pre5 set to be updated
---> Downloading header for wpa_supplicant to pack into transaction set.
wpa_supplicant-0.4.8-6.fc 100% |=========================|  11 kB    00:00
---> Package wpa_supplicant.i386 1:0.4.8-6.fc5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 mail-notification       i386       2.0-11.fc5       extras            338 k
Installing for dependencies:
 NetworkManager          i386       0.6.0-3          core              378 k
 NetworkManager-glib     i386       0.6.0-3          core               24 k
 bind                    i386       30:9.3.2-12.FC5  updates           929 k
 bind-config             i386       30:9.3.2-12.FC5  updates            50 k
 dhcdbd                  i386       1.12-1.FC5.2     core               68 k
 evolution               i386       2.6.0-1          core               12 M
 gnome-pilot             i386       2.0.13-7.fc5.4   core              540 k
 libnl                   i386       1.0-0.8.pre5     core              249 k
 pilot-link              i386       1:0.12.0-0.pre4.5.2.1  core              531 k
 wpa_supplicant          i386       1:0.4.8-6.fc5    updates           223 k

Transaction Summary
=============================================================================
Install     11 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 15 M
Is this ok [y/N]: N

This is some sick joke, right? Why do I need to install Evolution,
NetworkManager and BIND if I only want the mail-notification applet?

Version-Release number of selected component (if applicable):
mail-notification-2.0-11.fc5

How reproducible:
Always

Steps to Reproduce:
1. login as root
2. yum install mail-notification
3.
  
Actual results:
mail-notification and 15MB of bloat including evolution and bind gets installed.

Expected results:
mail-notification should not require evolution and bind. This is a client
system, after all, not a server.

Additional info:
Comment 1 Nigel Metheringham 2006-04-06 08:55:44 EDT
You need them because (for example) the evolution mailbox checker requires the
evolution libraries.  Evolution requires NetworkManager, NetworkManager requires
bind.

It may be possible to split the components for evolution out into a separate sub
package.

Evolution should probably also be repackaged to be more granular - which could
be could for Beagle etc as well.
Comment 2 Andrew Baumann 2006-06-27 22:38:54 EDT
Would it be possible to build a version of the mail-notification package 
without evolution support? This is what I've just done to avoid installing all 
the other crud.
Comment 3 Thorsten Leemhuis 2006-07-01 13:53:40 EDT
(In reply to comment #2)
> Would it be possible to build a version of the mail-notification package 
> without evolution support?

No easily afaics. It might be possible to just put the evolution-stuff from
/usr/lib/evolution/2.6/plugins/ into a subpackage. But I don't know if
mail-notification still works in that case. Would be helpfull if someone could
try (or even send/attach a patch)

Comment 4 Thorsten Leemhuis 2006-08-10 12:44:23 EDT
mail-notification-3_0-4_fc6 will fix this in devel. I probably won't fix it in
FC5, to risky.
Comment 5 Erik van Pienbroek 2006-09-23 06:02:30 EDT
I would like to report that this change has broken the expected behaviour for me.

I've installed a fresh FC6T3 installation and afterwards installed
mail-notification.
So I tried to configure mail-notification so that it connects to evolution.
I selected 'evolution' from the 'new mailbox' dialog, but no matter how many
times I restarted evolution, mail-notification, gnome or a whole reboot, the
'new mailbox' dialog keeps telling me that it can't connect to evolution...

While rebuilding the SRPMS on my own computer to investigate this issue I found
out that the evolution plugin (which needs to be used in evolution) was packaged
seperately (due to the change in this BZ). After installing the evolution plugin
and restarting evolution, mail-notification works inmediately.

So in the end, I got it all working, but how should a normal user know that for
mail-notification+evolution to work, the user needs to install a seperate plugin ?
Comment 6 Erik van Pienbroek 2006-09-23 07:06:46 EDT
To make it more clear to users that a seperate plugin needs to be installed,
I've created a patch which changes the following:
When a user opens the 'new mailbox' dialog, the program checks if the evolution
plugin is installed. If this is not the case, the option 'evolution' isn't
displayed in the mailbox-types combo-box. This should be enough to let the user
know that a additional plugin is necessary to connect mail-notification with
evolution.
Comment 7 Erik van Pienbroek 2006-09-23 07:08:31 EDT
Created attachment 136997 [details]
Patch which makes mail-notification hide the 'evolution' mailbox-type when the evolution plugin is not installed
Comment 8 Erik van Pienbroek 2006-09-23 07:09:46 EDT
Created attachment 136998 [details]
Necessary changes to the spec file to apply the evolution plugin-detection patch
Comment 9 Thorsten Leemhuis 2006-09-23 07:23:50 EDT
(In reply to comment #5)
> So in the end, I got it all working, but how should a normal user know that for
> mail-notification+evolution to work, the user needs to install a seperate plugin ?

It will be metioned in the release notes: 
http://www.fedoraproject.org/wiki/Docs/Beats/Extras
I just added it.


(In reply to comment #6)
> To make it more clear to users that a seperate plugin needs to be installed,
> I've created a patch which changes the following:
> When a user opens the 'new mailbox' dialog, the program checks if the evolution
> plugin is installed. If this is not the case, the option 'evolution' isn't
> displayed in the mailbox-types combo-box. This should be enough to let the user
> know that a additional plugin is necessary to connect mail-notification with
> evolution.

Nice. But running auto* stuff in the building process is a no-go for me. But I
can fix that myself
Comment 10 Thorsten Leemhuis 2006-09-23 07:45:50 EDT
(In reply to comment #7)
> Created an attachment (id=136997) [edit]
> Patch which makes mail-notification hide the 'evolution' mailbox-type when the
> evolution plugin is not installed

BTW, did you try to get this upstream? Could you get in contact the author and
ask for his opinion on this stuff? CC'ing me would be great. tia

Comment 11 Erik van Pienbroek 2006-09-23 07:58:39 EDT
(In reply to comment #10)
> BTW, did you try to get this upstream? Could you get in contact the author and
> ask for his opinion on this stuff? CC'ing me would be great. tia

This patch is just one hour old, so no, I haven't contacted the author yet. But
I'll send this patch to him and also CC it to you.

Note You need to log in before you can comment on or make changes to this bug.