Bug 187802 - metacity crashes on startup when used as a compositing manager
metacity crashes on startup when used as a compositing manager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 13:43 EDT by Dave Malcolm
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 16:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-04-03 13:43:06 EDT
Description of problem:
I tried enabling /apps/metacity/general/compositing_manager in GConf; metacity
crashes on startup everytime with this log:

GTK Accessibility Module initialized

ERROR!  sizeof(I830DRIRec) does not match passed size from device driver
libGL warning: 3D driver returned no fbconfigs.
libGL error: InitDriver failed
libGL error: reverting to (slow) indirect rendering
depth: 24
composite all asdf
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all adds window
composite all ends
Window manager warning: Log level 6: Unexpected X error: GLXUnsupportedPrivateRe
quest serial 650 error_code 162 request_code 143 minor_code 16)

Aborted

Version-Release number of selected component (if applicable):
Today's rawhide:
metacity-2.14.0-1
xorg-x11-server-Xorg-1.0.99.1-2

How reproducible:
100% on this hardware
Please let me know what other information I need to supply, or reassign
component as appropriate - thanks
Additional info:
Comment 1 Dave Malcolm 2006-04-04 16:56:30 EDT
Seems to be fixed in todays's rawhide

Note You need to log in before you can comment on or make changes to this bug.