Bug 187815 - Error loading files with non-standar ascii characters
Error loading files with non-standar ascii characters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ddd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 14:59 EDT by Diego Sánchez Román
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1229949 (view as bug list)
Environment:
Last Closed: 2006-04-20 11:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Sánchez Román 2006-04-03 14:59:38 EDT
Description of problem:

ddd doesn't show source code properly if it contains non-standar ascii characters

Version-Release number of selected component (if applicable):
ddd 3.3.11

How reproducible:
Load a program with non-standar ascii characters


Steps to Reproduce:
1.
2.
3.
  
Actual results:
ddd stops showing the source file when it finds the first non-standar ascii
character.

Expected results:
showing the source file properly.

Additional info:
It's not a bug in ddd because in other distros it works fine.
Comment 1 Ngo Than 2006-04-20 10:05:08 EDT
could you please attach a testfile to reproduce this bug? Thanks
Comment 2 Ngo Than 2006-04-20 11:41:17 EDT
It seems a problem in font setting. Could you please try to change the "Fixed
With" font to

lucidatypewriter-medium-r-normal-*-12-120-*-*-*-*-iso10646

It works fine for me with this font. I will add this font as default setting.
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.