Bug 187821 - Blank screen on Acer Aspire 1692
Blank screen on Acer Aspire 1692
Status: CLOSED DUPLICATE of bug 231359
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 15:29 EDT by Daniel Qarras
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 18:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of freshly booted Acer Aspire 1692 after running system-config-display (19.92 KB, text/plain)
2006-04-03 15:31 EDT, Daniel Qarras
no flags Details
X log after system-config-display has been run and ended with Ctrl+Alt+BS (911 bytes, text/plain)
2006-04-03 15:32 EDT, Daniel Qarras
no flags Details
dmesg with proprietary ATI driver from rpm.livna.org (19.92 KB, text/plain)
2006-04-14 10:40 EDT, Daniel Qarras
no flags Details
X log with proprietary ATI driver after starting and closing X (90.80 KB, text/plain)
2006-04-14 10:42 EDT, Daniel Qarras
no flags Details
my xorg.conf that works with ATI proprietary driver (3.94 KB, text/plain)
2006-04-14 10:42 EDT, Daniel Qarras
no flags Details
working xorg.conf for Acer Aspire 1692 (3.92 KB, text/plain)
2006-04-17 13:24 EDT, Daniel Qarras
no flags Details
dmesg after starting and quitting GNOME with Xorg ati driver (19.31 KB, text/plain)
2006-04-17 13:24 EDT, Daniel Qarras
no flags Details
X log after starting and quitting GNOME with Xorg ati driver (134.55 KB, text/plain)
2006-04-17 13:25 EDT, Daniel Qarras
no flags Details
Actual X log without MonitorLayout option using Xorg ati driver (147.58 KB, text/plain)
2006-08-29 13:06 EDT, Daniel Qarras
no flags Details
FC6 install time X.log (49.03 KB, text/plain)
2006-10-25 06:00 EDT, Daniel Qarras
no flags Details
FC6 install time XConfig.test (976 bytes, text/plain)
2006-10-25 06:00 EDT, Daniel Qarras
no flags Details
FC6 install time anaconda.log (11.88 KB, text/plain)
2006-10-25 06:01 EDT, Daniel Qarras
no flags Details
FC6 install time syslog (21.82 KB, text/plain)
2006-10-25 06:01 EDT, Daniel Qarras
no flags Details
Contents of /proc/acpi/video/VGA directory (638 bytes, application/x-gzip)
2007-01-30 11:24 EST, Daniel Qarras
no flags Details

  None (edit)
Description Daniel Qarras 2006-04-03 15:29:42 EDT
Description of problem:
I had to install FC5 in text because GUI did not start, screen stayed blank.
After installation when I run system-config-display screen goes blank and
nothing happens. Hitting Ctrl-Alt-BS gets me back to command prompt.

Version-Release number of selected component (if applicable):
FC5 + latest updates as of 2006-04-03.

How reproducible:
Always.

Steps to Reproduce:
1. Install FC5 to an Acer Aspire 1692 laptop
2. Run system-config-display
3. See how screen remains blank
  
Actual results:
Screen remains blank.

Expected results:
X configuration screen is shown.

Additional info:
I'll attach dmesg and X.setup.log outputs. Sticker on the laptop says:"ATI
Mobility Radeon X700 PCI Express With 128MB VRAM."
Comment 1 Daniel Qarras 2006-04-03 15:31:37 EDT
Created attachment 127251 [details]
dmesg of freshly booted Acer Aspire 1692 after running system-config-display
Comment 2 Daniel Qarras 2006-04-03 15:32:40 EDT
Created attachment 127252 [details]
X log after system-config-display has been run and ended with Ctrl+Alt+BS
Comment 3 Daniel Qarras 2006-04-09 05:42:41 EDT
So, any news on this? Fedora Core 5 on my laptop is practically useless until
this issue has been fixed. Please tell if you need more information and I'll
happily provide it. Thanks.
Comment 4 Daniel Qarras 2006-04-14 10:39:47 EDT
I got X running with ATI proprietary driver from rpm.livna.org.
system-config-display did not work without an existing xorg.conf. With the
attached xorg.conf both X and system-config-display work all ok. Please consider
fixing system-config-display and/or default X drivers so that I could get even a
low-resolution on my laptop.

I'll attach xorg.conf, dmesg, X.log.
Comment 5 Daniel Qarras 2006-04-14 10:40:40 EDT
Created attachment 127748 [details]
dmesg with proprietary ATI driver from rpm.livna.org
Comment 6 Daniel Qarras 2006-04-14 10:42:12 EDT
Created attachment 127749 [details]
X log with proprietary ATI driver after starting and closing X
Comment 7 Daniel Qarras 2006-04-14 10:42:57 EDT
Created attachment 127750 [details]
my xorg.conf that works with ATI proprietary driver
Comment 8 Daniel Qarras 2006-04-17 13:23:02 EDT
Good news! I finally managed to get X working on my laptop without ATI
proprietary driver. The key was to add the following line to xorg.conf in video
card section, without it the screen stays completely blank and even
system-config-display won't start. With it both GNOME/X and
system-config-display work ok (1200x800@24).

        Option      "MonitorLayout" "LVDS"

I'll attach my full xorg.conf and both dmesg output and Xorg.log after starting
and quitting GNOME.
Comment 9 Daniel Qarras 2006-04-17 13:24:02 EDT
Created attachment 127814 [details]
working xorg.conf for Acer Aspire 1692
Comment 10 Daniel Qarras 2006-04-17 13:24:51 EDT
Created attachment 127815 [details]
dmesg after starting and quitting GNOME with Xorg ati driver
Comment 11 Daniel Qarras 2006-04-17 13:25:32 EDT
Created attachment 127816 [details]
X log after starting and quitting GNOME with Xorg ati driver
Comment 12 Daniel Qarras 2006-05-29 04:57:44 EDT
So what's the status with this? All information needed should be available to
roll out a package containing needed fixes. Thanks.
Comment 13 Adam Jackson 2006-08-28 16:19:05 EDT
The X log attached for the failure case is just the stderr output, not the log
file.  What does the log look like if you start X without the MonitorLayout option?
Comment 14 Daniel Qarras 2006-08-29 13:06:25 EDT
Created attachment 135154 [details]
Actual X log without MonitorLayout option using Xorg ati driver

Sorry for the previous incorrect log, this log now really contains X log after
executing startx and ending the sessions with Ctrl+Alt+BS because screen
remained blank. My system is FC5 plus all the updates to date.
Comment 15 Daniel Qarras 2006-09-20 16:21:23 EDT
The installer still halts, screen remain blanks after a few moment with FC6t3.
Please advise.
Comment 16 Daniel Qarras 2006-10-24 16:49:05 EDT
This is still happening with Fedora Core 6 (Zod) Final.
Comment 17 Daniel Qarras 2006-10-25 05:58:47 EDT
I will attach logs generated when attempted to install FC6 in graphical mode.
Comment 18 Daniel Qarras 2006-10-25 06:00:02 EDT
Created attachment 139324 [details]
FC6 install time X.log
Comment 19 Daniel Qarras 2006-10-25 06:00:48 EDT
Created attachment 139325 [details]
FC6 install time XConfig.test
Comment 20 Daniel Qarras 2006-10-25 06:01:21 EDT
Created attachment 139326 [details]
FC6 install time anaconda.log
Comment 21 Daniel Qarras 2006-10-25 06:01:51 EDT
Created attachment 139327 [details]
FC6 install time syslog
Comment 22 Daniel Qarras 2006-11-23 12:32:05 EST
I don't want to push you but it's been three months without any comments and
over half a year since this bug was created and still you can't use Fedora Core
on an Acer Aspire 1692 without resorting to manually tinker with a config file
that should be automagically adjusted by system-config-display.

If you need some additional information please say so and I'll be delighted to
provide if to you.

Thanks.
Comment 23 Adam Jackson 2007-01-30 10:03:46 EST
This one's pretty weird.  We don't get DDC from the panel, and we don't seem to
find any timing info for it in the BIOS, and there's certainly no VGA attached.
 So we're trying to do 800x600 as the fallback, but apparently even that fails.

So we may be stuck, unless there's another way out.  Do you have any
subdirectories underneath /proc/acpi/video ?
Comment 24 Daniel Qarras 2007-01-30 11:23:29 EST
Thanks for looking into this. Indeed, there is "VGA" subdirectory. I've attached
its contents as a tar.gz archive.

Cheers!
Comment 25 Daniel Qarras 2007-01-30 11:24:47 EST
Created attachment 146928 [details]
Contents of /proc/acpi/video/VGA directory
Comment 26 Adam Jackson 2007-03-26 16:25:14 EDT
Okay, so looking for EDID in ACPI was a dead end.

The real problem here is that we're not finding the connector table.
Comment 27 Adam Jackson 2007-04-02 18:14:47 EDT

*** This bug has been marked as a duplicate of 231359 ***

Note You need to log in before you can comment on or make changes to this bug.