Bug 187822 - kdebase: --enable-dnssd
Summary: kdebase: --enable-dnssd
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-03 19:29 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 17:27:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2006-04-03 19:29:46 UTC
Enable DNS-SD support in kdebase.

+BuildRequires: avahi-devel

Add to %configure:
--enable-dnssd \
--with-extra-includes="$(pkg-config --cflags-only-I avahi-compat-libdns_sd)"

Comment 1 Rex Dieter 2006-04-04 18:08:04 UTC
Turns out the --with-extra-includes doesn't work here (it did for me in
kdelibs).  Instead, add before %configure:

CPPFLAGS="$(pkg-config --cflags-only-I avahi-compat-libdns_sd)"

Comment 2 Rex Dieter 2006-04-05 12:49:12 UTC
Ack, last time, I promise.  (-:  I can vouge that this actually works:

export CPPFLAGS="$CPPFLAGS $(pkg-config --cflags-only-I avahi-compat-libdns_sd)"


Comment 3 Rex Dieter 2006-05-15 13:45:40 UTC
Apparently, avahi's compatibility layer, isn't all that compatible in this case.
 ksysguard crashes (for me) on fc5 with this enabled:

$ ksysguard
*** WARNING *** The programme 'ksysguard' uses the Apple Bonjour compatibility
layer of Avahi
...
ksysguard: compat.c:348: sdref_free: Assertion '__ret == 0' faild
compat.c: read() failed: Connection reset by peer.
...
KCrash: Appliction 'ksysguard' crashing...

Comment 4 Rex Dieter 2006-05-17 17:27:12 UTC
Nevermind on this one, for now.  avahi's compatibility layer sucks rocks.


Note You need to log in before you can comment on or make changes to this bug.