Bug 187831 - Kernel hangs loading dm-snapshot.ko module
Kernel hangs loading dm-snapshot.ko module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 15:44 EDT by David Bentley
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 00:05:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Bentley 2006-04-03 15:44:13 EDT
Description of problem:
Kernel hangs loading dm-snapshot.ko module

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2114_FC6

How reproducible:
allways

Steps to Reproduce:
reboot after new kernel is installed

Actual results:
hangs 
last 4 lines as follows :-

device-mapper:4.6.0-ioctl (2006-02-17) initialized: dm-devel@redhat.com
loading dm-mapper.ko module
loading dm-zero.ko module
loading dm-snapshot.ko module

Expected results:
boot as normal

Additional info:

kernel 2097 is the last to work OK and from dmesg output uses
device-mapper: 4.5.0-ioctl (2005-10-04) initialised: dm-devel@redhat.com

Gigabyte GA7ZXR with windows 2000 setup on 2x30gig drives mirrored using the
onboard promise fasttrak lite raid controller.

NB all kernels post 2097 have failed in this manner.
Comment 1 David Bentley 2006-04-10 11:32:16 EDT
NB this is still happening with the latest rawhide kernel.
Comment 2 David Bentley 2006-04-17 09:31:14 EDT
Tested again with todays kernel (2134) and it now fails at a slightly erlier
point  in the boot process.

No output after the following :-

device-mapper:4.6.0-ioctl (2006-02-17) initialized: dm-devel@redhat.com

Comment 3 David Bentley 2006-04-20 05:06:33 EDT
Is there any boot time kernel parameter that I could use to get round this 
problem or is there any way of getting any more info that may be of use 
tracking down the cause of the problem.
Comment 4 David Bentley 2006-04-22 15:27:32 EDT
Note that this system that is tracking the development tree was converted from a
fresh FC5 install dual booting with XP Pro on the same disc and not using LVM
partitioning. On the same system I have a 4gig scsi drive with win98se and a
pair of 30gig discs mirrored with win2k.
Comment 5 David Bentley 2006-05-11 13:04:58 EDT
Still a problem with the latest kernel (2200) as it fails in exacltly the same
way as 2134 did from comment #2
Comment 6 David Bentley 2006-05-20 07:02:55 EDT
Kernel 2207 first kernel to boot on my test system since 2097 any idea what
changed to fix this. The last one I tried which still failed was 2204 I think.
Comment 7 Dave Jones 2006-06-23 00:05:40 EDT
reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.