Bug 187835 - Can not "startx" on either PCI video card for RADEON9200 series
Can not "startx" on either PCI video card for RADEON9200 series
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-03 16:13 EDT by Robert Margossian
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 11:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xconf.org (4.49 KB, application/octet-stream)
2006-04-03 16:38 EDT, Robert Margossian
no flags Details
Xorg log for failure with attached xorg.conf in Fc5 (66.00 KB, text/plain)
2006-04-03 16:40 EDT, Robert Margossian
no flags Details

  None (edit)
Description Robert Margossian 2006-04-03 16:13:21 EDT
Description of problem:
I have seen similar issues posted here, but not entirely the same. I can only
uset the on-board Intel card. I can use the PCI Radeon card in text mode only. I
am getting a "clock" error trying to start either card with the radeon driver. X
crashes:



Version-Release number of selected component (if applicable):


How reproducible:
100 %

Steps to Reproduce:
1.edit xorg.cong, add screen, monitor, device with radeon drive on correct pci
bus id
2.startx
3.
  
Actual results:
X crashes

Expected results:

with fc4 and same configuration (xorg.conf) x started on 3 heads without incident
Additional info:

Have to restart with 3 head xorg to get the actual log. Will resatrt, attach the
log, and the xorg.conf

I have done the same upgrade at my offie, using 3 heads, using two nvidia pci
cards, copying the fc4 xorg.conf to the new fc5 install, and it works without
incident.
Comment 1 Robert Margossian 2006-04-03 16:38:59 EDT
Created attachment 127257 [details]
xconf.org

This works with fc4 using 3 heads, one on baord intel card, two radeon pci
cards. This fails on fc5
Comment 2 Robert Margossian 2006-04-03 16:40:04 EDT
Created attachment 127258 [details]
Xorg log for failure with attached xorg.conf in Fc5

Corresponding log for xorg.conf that works for fc4 bu fails for fc5
Comment 3 Robert Margossian 2006-04-03 17:06:03 EDT
FYI....After reading many of the other bugs related to radeon driver as reported
here, I also tried with "dri", but still get the same error as lisetd in the
attached log for X. I ave chased this bug since fc5 was released this past
month, but am convinced it is related to the new radeon driver. Please advise
Comment 4 Mike A. Harris 2006-05-19 05:43:56 EDT
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 5 Robert Margossian 2006-06-03 14:01:16 EDT
Bug Opened....

URL : https://bugs.freedesktop.org/show_bug.cgi?id=7104
Comment 6 Mike A. Harris 2006-06-14 11:24:48 EDT
Thanks, tracking in X.Org bugzilla now.  When a fix is available, we'll
review it for consideration in future updates.

Setting status to UPSTREAM.


Note You need to log in before you can comment on or make changes to this bug.