Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1878753 - RFE: Allow atd(at-3.1.20-11.el8) to default to a non-root user
Summary: RFE: Allow atd(at-3.1.20-11.el8) to default to a non-root user
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: at
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Ondřej Pohořelský
QA Contact: RHEL CS Apps Subsystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-14 13:13 UTC by XinhuaLi
Modified: 2020-12-15 09:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-15 09:54:56 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description XinhuaLi 2020-09-14 13:13:56 UTC
Description of problem:
I notice that atd service which shipped with RHEL8.2 is still running as "root" user.
-----------------------------------------------------------------------------------
# ps -aux |grep -i atd
root        1824  0.0  0.0  42624  2468 ?        Ss   Sep11   0:00 /usr/sbin/atd -f
-----------------------------------------------------------------------------------

As we can know that we are using the source from the URL below 
-----------------------------------------------------------------------------------
Name        : at
Version     : 3.1.20
Release     : 11.el8
Architecture: x86_64
Install Date: Wed 06 May 2020 05:42:21 PM CST
Group       : System Environment/Daemons
Size        : 130702
License     : GPLv3+ and GPLv2+ and ISC and MIT and Public Domain
Signature   : RSA/SHA256, Sat 15 Dec 2018 05:45:55 AM CST, Key ID 199e2f91fd431d51
Source RPM  : at-3.1.20-11.el8.src.rpm
Build Date  : Sun 12 Aug 2018 04:43:08 PM CST
Build Host  : x86-vm-02.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://ftp.debian.org/debian/pool/main/a/at
Summary     : Job spooling tools
-----------------------------------------------------------------------------------
It seems that we could run this "atd" without "root" user. 
-----------------------------------------------------------------------------------
https://salsa.debian.org/debian/base-passwd/blob/master/doc/users-and-groups.sgml
-----------------------------------------------------------------------------------

So, are there any considerations why atd shipped with RHEL8.2 is still running with "root"  ?

Version-Release number of selected component (if applicable):
-----------------------------------------------------------------------------------
at-3.1.20-11.el8.x86_64
-----------------------------------------------------------------------------------

How reproducible:
-----------------------------------------------------------------------------------
Install at and then check via "ps -aux |grep atd"
-----------------------------------------------------------------------------------

Steps to Reproduce:
-----------------------------------------------------------------------------------
1. install "at" 
2. enable "atd"
3. check via "ps -aux |grep atd"
-----------------------------------------------------------------------------------

Actual results:
-----------------------------------------------------------------------------------
# ps -aux |grep -i atd
root        1824  0.0  0.0  42624  2468 ?        Ss   Sep11   0:00 /usr/sbin/atd -f
-----------------------------------------------------------------------------------

Expected results:
-----------------------------------------------------------------------------------
It runs as other user like 

# ps -aux |grep -i atd
daemon        1824  0.0  0.0  42624  2468 ?        Ss   Sep11   0:00 /usr/sbin/atd -f
-----------------------------------------------------------------------------------
Additional info:

Comment 6 Ondřej Pohořelský 2020-12-15 09:54:56 UTC
Because this is not a bug and customer case is closed, I close this with NOTABUG.

Feel free to reopen if this is a bug that should be fixed.


Note You need to log in before you can comment on or make changes to this bug.