Bug 1878755 - Image stream tags referenced by default cluster loader tests is not present in OCP 4.5. [NEEDINFO]
Summary: Image stream tags referenced by default cluster loader tests is not present i...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Loader
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Andrew Bond
QA Contact: Walid A.
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-14 13:15 UTC by Martin Eggen
Modified: 2021-06-22 21:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-31 15:09:26 UTC
Target Upstream Version:
oarribas: needinfo? (abond)
oarribas: needinfo? (abond)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1859738 0 medium CLOSED [DOC] Cluster Loader example test does not exist 2021-06-22 21:43:11 UTC
Red Hat Bugzilla 1909041 0 unspecified CLOSED Incorrect deployment of cake-php-mysql template leaving the cluster loader test to fail 2021-06-22 21:43:01 UTC
Red Hat Knowledge Base (Solution) 5720441 0 None None None 2021-06-22 21:43:06 UTC

Internal Links: 1859738 1909041

Description Martin Eggen 2020-09-14 13:15:02 UTC
Description of problem:

The PHP image stream tag referenced by default cluster loader test is not present in OCP 4.5.

The image build and dependent deployment of clusterloader-cakephp will fail as the build configuration refers to an image stream tag (php:7.1) that does not exist in OCP 4.5. It's necessary to manually patch the build config to refer to an existing image stream tag tag (php:7.2) for the build to trigger and the deployment to run so that the default test can complete.

Version-Release number of selected component (if applicable):

OCP 4.5
e2e test version: v1.18.3

How reproducible:

Always
[1] https://docs.openshift.com/container-platform/4.5/scalability_and_performance/using-cluster-loader.html

Steps to Reproduce:
1. Run cluster loader with default configuration as described in [1].
2. The image build of cakephp-mysql-example:latest will fail as the build configuration refers to a php tag that does not exist in OCP 4.5.
3. The cakephp-mysql-example deployment is stuck waiting for the cakephp-mysql-example:latest image that is never built due to the above error.

Actual results:

Sep 14 11:14:41.068: INFO: Waiting for RC: mysql-1
Sep 14 11:14:43.084: INFO: Build List: &BuildList{ListMeta:{/apis/build.openshift.io/v1/namespaces/clusterloader-cakephp-mysql0/builds 48363  <nil>},Items:[]Build{},}
Sep 14 11:14:43.091: INFO: Waiting for deployment: "cakephp-mysql-example"
Sep 14 11:14:43.092: INFO: waiting for deploymentconfig clusterloader-cakephp-mysql0/cakephp-mysql-example to be available with version 1

# oc get bc -n clusterloader-cakephp-mysql0 cakephp-mysql-example -o yaml | grep -A3 from:

      from:
        kind: ImageStreamTag
        name: php:7.1
        namespace: openshift

# oc get is -n openshift php

NAME   IMAGE REPOSITORY                                                 TAGS             UPDATED
php    image-registry.openshift-image-registry.svc:5000/openshift/php   7.2,7.3,latest   2 hours ago

# oc patch -n clusterloader-cakephp-mysql0 bc  cakephp-mysql-example -p '{"spec":{"strategy":{"sourceStrategy":{"from":{"name":"php:7.2"}}}}}'
buildconfig.build.openshift.io/cakephp-mysql-example patched

# oc get -n clusterloader-cakephp-mysql0 builds
NAME                      TYPE     FROM          STATUS    STARTED          DURATION
cakephp-mysql-example-1   Source   Git@377fe8f   Running   29 seconds ago
 
Expected results:

The test build configuration should refer to php:7.2 so that the cakephp-mysql-example build triggers automatically and the default cluster loader test completes.

Additional info:

Comment 1 Martin Eggen 2020-09-14 23:45:08 UTC
Image stream tags have already been bumped for OCP 4.4 to php:7.2 in https://github.com/openshift/svt/commit/790e8bfe0848a18c9492af02ae2242dbbab1c00b - however running quay.io/openshift/origin-tests:4.5 as described in https://docs.openshift.com/container-platform/4.5/scalability_and_performance/using-cluster-loader.html#running_cluster_loader_ still uses a config that refers to php:7.1.

Comment 2 Martin Eggen 2020-10-22 10:32:44 UTC
We see the same issue with the default nodejs templates used that refer to nodejs versions not present in OCP 4.5:

https://github.com/openshift/origin/blob/release-4.5/examples/quickstarts/nodejs-mongodb.json#L435-L441 defaults to use nodejs:8 while only 10 and 12 tags are present on OCP 4.5:

$ oc get is -n openshift nodejs
NAME     IMAGE REPOSITORY                                                                               TAGS           UPDATED
nodejs   image-registry.openshift-image-registry.svc:5000/openshift/nodejs                              10,12,latest   7 weeks ago

Comment 3 oarribas 2021-01-20 17:14:43 UTC
The tags available at this moment for the php imagestream are "7.2-ubi8,7.3,7.3-ubi7,7.3-ubi8,latest"

~~~
# oc get is -n openshift php
NAME   IMAGE REPOSITORY                                                 TAGS                                    UPDATED
php    image-registry.openshift-image-registry.svc:5000/openshift/php   7.2-ubi8,7.3,7.3-ubi7,7.3-ubi8,latest   2 weeks ago
~~~

Comment 8 oarribas 2021-05-31 15:09:26 UTC
Cluster Loader is deprecated in 4.8 [1][2], and will be removed in 4.9.



[1] https://github.com/openshift/openshift-docs/pull/32702
[2] https://github.com/openshift/openshift-docs/pull/32703


Note You need to log in before you can comment on or make changes to this bug.